UI Formula not applying on all rows...

DaveDave 💎
edited June 25, 2020 in Questions
Hi Guys another weird issue

I have a model with transactions and running a UI only formula to determine if it's a Deposit or a Debit ( i use same formula on other skuid pages with no issue)

IF({{amount}}>0,"Deposit", "Debit")

for some reason on any record I preview, on some rows it applies but on others no. I tried rebuilding completely the model, works for a bit then again randomly breaks..

Any ideas?

image


Comments

  • Pat VachonPat Vachon 💎💎💎
    edited June 25, 2020
    Is there always an amount value?
  • DaveDave 💎
    edited June 3, 2020
    HI Pat,

    of course! as you can see on screenshot above, the second column is the amount and as you can see has values.

    Looking more into it I think it's related to another issue I posted a couple days ago

    https://community.skuid.com/skuid/topics/table-row-count-footer-correct-but-table-not-displaying-all-rows

    As on that same table, when it first loads the row count is good (500), but unless I requery after loading the # of rows is very low. (like 3-4 records show)

    Once i Requery Model, with model actions, it displays proper #

    But this morning I tried to 'Load more' records (500 more) and realized that I cannot, it loads 3-4 more records and now instead of seeing example 1000 records, on table only 6-7 records appear total

    Very weird and totally confused.

    Hope someone from Skuid can get back to me soon, before I lose the little hair I have left on my head :D





  • Rob HatchRob Hatch 🛠️ 
    edited June 3, 2020
    Look at the answer I just gave to your linked post.  That may solve the problem here too. 

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!