Table components with "Allow Scroll Bars" not showing any data until you click on stuff (Lightning 1

edited July 11, 2019 in Questions
^ as described above. This is quite a big one for us. Seems maybe to only affect new pages?

If there's a quick css fix we can add to the page could someone let us know?




  • edited September 17, 2018
    This is what it looks like:

  • edited July 11, 2019
    Did we not have a bunch of extra conversation on this thread? I wonder if maybe I'm just losing my mind.
  • edited September 19, 2018
    Any ideas what's going on here? Not re. the losing of my mind but re. the losing of some of the posts on this page. I'm not sure if you saw my responses to your responses. I'm still having this issue even with the XML you provided to me (remove the table height property). Can someone please get back to me on this?
  • edited September 21, 2018
    Can someone from Skuid please help with this? It's getting quite urgent.
  • edited September 21, 2018
    It also seems to happen to the table component in Lightning when you click onto a record in that table and then click the back button in the browser - when you navigate back to the previous record all the rows are removed and only show up again when you click on something in the table component. Interestingly - in all these cases - opening the Chrome Developer Tools forces the rows to pop back in. Bizarre. Same in Firefox.
  • edited September 21, 2018
    I haven't been able to reproduce this problem. Can you share your XML of the problem?
  • edited April 15, 2019
    Hi Stephen, yes - absolutely. This XML is used in a fresh 11.2.9 install using the Skuid Lightning Component in a record detail page (custom object). Also about to provide login access. Thank you!

    <skuidpage unsavedchangeswarning="yes" personalizationmode="server" showsidebar="true" useviewportmeta="true" showheader="true">
            <model id="OppsModel" limit="20" query="true" createrowifnonefound="false" datasource="salesforce" sobject="Opportunity">
                    <field id="AccountId"/>
                    <field id="Account.Name"/>
                    <field id="Amount"/>
                    <field id="CloseDate"/>
                    <field id="Description"/>
                    <field id="Fiscal"/>
                    <field id="Id"/>
                    <field id="Type"/>
            <skootable showconditions="true" showsavecancel="true" showerrorsinline="true" searchmethod="server" searchbox="true" showexportbuttons="false" hideheader="false" hidefooter="false" pagesize="100" alwaysresetpagination="false" createrecords="true" model="OppsModel" buttonposition="" mode="read" allowcolumnreordering="true" responsive="true" uniqueid="sk-3izY-296" allowscrollbars="true" floatheader="true" freezeleftcolumns="true" columnstofreeze="1">
                    <field id="AccountId" uniqueid="fi-3izY-297"/>
                    <field id="Account.Name" uniqueid="fi-3izY-298"/>
                    <field id="Amount" uniqueid="fi-3izY-299"/>
                    <field id="CloseDate" uniqueid="fi-3izY-300"/>
                    <field id="Description" uniqueid="fi-3izY-301"/>
                    <field id="Fiscal" uniqueid="fi-3izY-303"/>
                    <field id="Type" uniqueid="fi-3izY-305"/>
                    <action type="edit"/>
                    <action type="delete"/>
                <massactions usefirstitemasdefault="true">
                    <action type="massupdate"/>
                    <action type="massdelete"/>
                    <view type="standard"/>
            <actionsequences uniqueid="sk-3izS-249"/>
            <styleitem type="background" bgtype="none"/>

  • edited September 21, 2018
    This is a known Skuid issue. We'll notify here when a fix goes live.

    Allow Scroll Bars" on Tables in Lightning won't show the data in the table on page load unless "Max Table Height (Optional)" is set. And if it is set, it won't appear properly.
  • edited September 25, 2018
    My temporary fix for this is a "Skuid Page:Rendered" triggered snippet which waits for a second and then re-renders the table via component id:

    setTimeout(function () {
    }, 1000);
  • edited November 30, 2018
    Any updates on this? It's driving me round the bend.
  • edited October 29, 2018
    It should be coming out in the next release or the one after that.
  • edited November 2, 2018
    Hello Stephen - being able to show a table on a Skuid page, to me, seems completely fundamental - can we please have a date by which this will be fixed?
  • edited November 6, 2018
    Looks like this was addressed in the latest release - will install and test and let you know if there any issues :)
  • edited November 8, 2018
    I'm afraid this fix hasn't worked - I still have exactly the same issue - could I get an update? Cheers! I've tried this after clearing all cookies etc. 
  • edited November 8, 2018
    Have you tried in 11.2.11? That is suppose to have the fix
  • edited November 8, 2018
    Yeah, that's the release I'm testing. I saw it in the release notes but maybe the fix didn't make it in?
  • edited November 8, 2018
    The fix made it in and the XML on this post is being used as the source of reproduction. I just tried the reproduction page and see that it is working in our org. We currently have no reproduction of this.

    What Instance are you in? What browser and version? What kind of computer are you using? 
  • edited November 8, 2018
    Hi Stephen,

    I've done further testing and the issue is on Mac Chrome, Mac Firefox and Windows Edge - they're just the browsers I've tested - so it's not related to my setup.

    We're seeing it in both Production and in a Dev Org.

    Sometimes it now works if you visit a different skuid page first, but it's inconsistent.

    I've granted login access (00D1t000000GWX9) - you can reproduce by going to the "Charity App" and then clicking the "Finance" tab (in Lighting obvs).

  • edited November 8, 2018
    I was able to login and see what you're seeing? Is this the only place you've seen this happen or are there other locations. Can you reproduce it using standard objects and fields? So far I can't replicate it outside your org
  • edited November 8, 2018
    It's also taking happening on the Membership tab, Administration tab and also one of the record pages (Invoice, I think) - but some of them currently have the re-render fix deployed (see above). I've removed this from the Membership tab so you can take a look.

    I've created a new Lightning App tab (Skuid Test) and put the above XML in and it's working fine. I then tried putting the Membership tab XML into the new page and it's working fine... But now the old Membership page is also working. Very strange. Feel free to play with the Skuid Test tab and NewSkuidTest page.
  • edited November 10, 2018
    I also often see this behaviour when I click the back button in the browser - the table on the previous page is now empty.
  • edited November 27, 2018
    If it happens with the back button, that highly indicates its a caching issue. Have you cleared your cache since upgrading? 
  • edited November 27, 2018
    Yep, so many times, and across many different computers and devices - sorry! I've also used fresh browsers not previously installed on one of these devices.
  • edited November 27, 2018
    Here's another example but with a very simple Skuid page produced by hopping to a different browser tab whilst the page loads:
  • edited November 27, 2018
    I can't reproduce the behaviour I'm seeing above when I turn off scroll-bars on the table.
  • edited November 29, 2018
    I've been able to reproduce this issue in 11.2.11. We'll be working on it. Thank you again for posting this
  • edited November 30, 2018
    Doing a hard reset of the cache in Chrome via View > Developer > Developer Tools > Application > "Clear Site Data" makes this problem intermittent instead of every time. It will work about 60% of the time instead of 0% of the time. At least, this is what we are seeing
  • edited November 30, 2018
    Thanks Stephen, I'm glad you guys are seeing similar behaviour. It seems to be more likely to occur when larger volumes of data are being loaded into the page (though at volumes that wouldn't have been an issue in the past). It's like the rendering process on the table rows is waiting to be triggered only once the data has returned, but where this trips over for whatever reason (a bit more data or some other interruption) the trigger to display the rows never gets fired (or gets fired too soon?). It's a new problem, as we've been doing stuff in Lightning for some time and it's not been an issue before. I couldn't tell you which version introduced it though, maybe 11.2.9? But I really don't know.
  • edited November 30, 2018
    In Charity App -> Finance/Membership tabs in org id 00D1t000000GWX9 (you've got access) you can reproduce it pretty much every time. Especially if you refresh the page from those tabs.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!