Sandbox Refresh Displaying Old Versions of Skuid pages

Danny HartleyDanny Hartley Member
edited September 2019 in Problems
The last two times we have refreshed our sandbox, there are some Skuid pages that are displaying as older versions of the Skuid pages.  After refresh, Production Account Skuid Page != Sandbox Account Page, for example.  Anyone know what is causing this?

Comments

  • Stephen SellsStephen Sells Member
    edited September 2018
    What was your version of Skuid before and after upgrade?

    We haven't had any reportings of this prior. 
  • Danny HartleyDanny Hartley Member
    edited September 2018
    The versions look the same.  I have attached screenshots for you to confirm. Production Account:

  • Danny HartleyDanny Hartley Member
    edited September 2018
    Sandbox Account:

    image
  • Danny HartleyDanny Hartley Member
    edited September 2018
    Production Package:

    image
    Sandbox Package:image

    Sandbox Refresh:

    image
  • Stephen SellsStephen Sells Member
    edited September 2018
    Are versions saved on your page? Are you able to bring the page to the new version? I'm assuming the first picture is the desired result. Is that correct?
  • Danny HartleyDanny Hartley Member
    edited September 2018
    That old version is from many months ago, maybe more than a year.  I haven't checked, but I assume that a version that old would not be kept?
  • Stephen SellsStephen Sells Member
    edited September 2018
    The version that old may or may not be kept. Is the new one also available?
  • Mike DwyerMike Dwyer Member
    edited September 2019
    Do you happen to have the old page versions in a different Module than the new versions? [You can guess where I've been burned before, although the symptoms were different.]
  • Danny HartleyDanny Hartley Member
    edited September 2018
    Sorry, I thought I had included a shot of the desired result.  Here is the production version / desired result:

    image
  • Danny HartleyDanny Hartley Member
    edited September 2018
    It doesn't look like we have any pages in modules.  Granted, I am not positive I am looking in the right place
    image
  • Mike DwyerMike Dwyer Member
    edited September 2018
    You are looking in the right place for my curiosity. I would suggest clicking that Module:skuid selection on the upper right and see if any pages turn up there. What I am thinking is a situation where the same page name exists in No Module and in Module:Skuid.
  • Danny HartleyDanny Hartley Member
    edited September 2018
    The only items in Module: Skuid look to be standard Skuid pages:image
  • Mike DwyerMike Dwyer Member
    edited September 2018
    Well, rules out that possibility.
  • Danny HartleyDanny Hartley Member
    edited September 2018
    Thanks for the suggestion
  • Stephen SellsStephen Sells Member
    edited September 2018
    Have you brought over the pages in a page pack? Do you still have access to the finished/better pages? Does bringing them over directly - even if it is just copying and pasting the XML over - work?
  • Danny HartleyDanny Hartley Member
    edited September 2018
    I have not brought them over in a page pack.  Is that something that needs to happen whenever we refresh sandbox?

    I have access to the current pages in production.

    Copy/pasting the XML works, but I was just trying to understand the root cause so that we can avoid having to copy/paste each refresh.
Sign In or Register to comment.