Error with Skuid Page in Lightning Community Builder

Eulogio Gallo
edited February 4, 2020 in Questions
I have some simple Skuid tables that I am embedding into my Napili Community via the Community Builder and Skuid custom component. These were functioning correctly yesterday, but today I'm no longer able to see the pages in either sandbox or production.  I received this error in production:

"Cannot add Inline Javascript in the Lightning Runtime, and no Page Support File was found or there was a timeout."

We are trying to launch our community next week, and these features are critical. Any advice on this would be appreciated.



  • Stephen Sells
    edited August 17, 2018
    Did anything change between yesterday and today? ie upgrade, add javascript, change the pages, activate the community, etc.

    Is there custom javascript on the pages? If so, do the pages work without it? If so, there is likely a problem with the custom javascript on your page.
  • Eulogio Gallo
    edited August 17, 2018
    Hi Stephen,

    Yes I did activate the community this morning, do you think that would cause issues? I'm not sure why that would affect the already active sandbox community though.

    My page does have a small amount of javascript, but again this was working in the sandbox before this morning.

  • Stephen Sells
    edited August 17, 2018
    What does the Javascript do?
    Do the pages work without any of it? Absolutely scrapped, do your pages load?
  • Eulogio Gallo
    edited August 17, 2018
    The page loads fine within our internal Salesforce, but won't for the Community. I removed the javascript and it still does not load in Community.
  • Eulogio Gallo
    edited August 22, 2018
    I'm adding a screenshot of the browser console's output, hope this helps.

  • Eulogio Gallo
    edited August 17, 2018
    And this error pops up in the Lightning Community Builder:

    Uncaught TypeError: Cannot read property 'call' of null throws at
  • Chandra V
    edited February 25, 2019
    Make sure in your new environment (production?) you click Generate Page Support Files on your skuid pages that contain javascript.  It's always a good idea to do that anytime you copy a page over to a new environment from a sandbox.
  • Eulogio Gallo
    edited August 22, 2018
    Thanks for the advice Chandra, I've one ahead and generated the support files. What do I do now?
  • Stephen Sells
    edited August 22, 2018
    Is this the error you're seeing after you've removed all javascript from the page?

    What are you seeing for your pages themselves when a user tries to access the community? We need much more detail to be able to help
  • Eulogio Gallo
    edited August 22, 2018
    Yes, the error still shows if I remove the js.

    Here is a screenshot of what users see in the Community. It simply doesn't show.
  • Eulogio Gallo
    edited August 22, 2018
    The Skuid table should be showing below the text blurb.
  • Stephen Sells
    edited August 22, 2018
    Does the end user have permission to see the page? Has it been set to public? We see this from time to time relating to permissions. Considering you suddenly can't see it after activation, this is a likely culprit worth exploring.

    Is it a detail page or something attached to an object? The permissions will need to be set to public if it is a public community
  • Eulogio Gallo
    edited August 22, 2018
    The Skuid page isn't embedded in a Visualfore page, I'm using the Skuid Community Builder component to embed in my community. Is there some 'Public' setting I have to do for this? It was working fine in the sandbox community I had before I tried moving to production.

    Below is what it should look like. Again, it's a pretty straightforward table of info, nothing too fancy about it.  It is pulling Contact info.
  • Stephen Sells
    edited August 22, 2018
    Is the text in a Skuid page? What is your lightning page builder looking like?
  • Stephen Sells
    edited August 22, 2018
    Many times, you actively have to go give permission to be able to see certain objects in community. If the table is on an object that doesn't have permissions, the end user won't see it.
  • Eulogio Gallo
    edited August 22, 2018
    No the text isn't on a Skuid page. The only thing that is Skuid is the table shown in the pic above. See this pic for the Community Builder I'm using:

    This page also throws the following error:
    Uncaught TypeError: Cannot read property 'call' of null throws at

    I made sure that Contact permissions are enabled. We have another Community that is active that functions correctly with our permissions, but this is the first time we're trying to add a Skuid component to this.
  • Zach McElrath
    edited August 23, 2018
    After you generate the Page Support Files for your pages, those pages should be usable in Lightning.
  • Eulogio Gallo
    edited August 23, 2018
    Hi Zach,

    I generated the support file and that removes the error messages, but nothing actually shows up on the page still. Do you think it has anything to do with the gatherer.js script? I notice that the resource URLs it is referring to are incorrect. For example: 

    This gives me a 503 error. But if I use the correct Community path: 
    This downloads the resources correctly. I wonder if this other URL is having similar troubles with the links not pointing to the correct path: 
    What do you think?

  • Mark DeSimone
    Mark DeSimone 🛠️ 
    edited February 4, 2020
    Hi Eulogio,

    It sounds like generating the support files was a necessary step, but there's another unresolved issue to understand. Would you mind telling us your current Skuid release #, and whether you've recently upgraded?

    Also, in Chrome's developer tools, sometimes I can find out more information by looking in the Network tab for resources that didn't load, or returned an error. If you can share anything that doesn't look like a '200' that'd be helpful too. 
  • Eulogio Gallo
    edited August 24, 2018
    Hi Mark,

    We are currently on 11.2.7. I updated from 11.2.2 this week in hopes of fixing this Community issue.

    Using the Network tab, the only non-200 message I see is the one I referenced in the comments above - 503:

    One thing I'm seeing though is that the page will continuously make a request to aura?r=361&skuid.SkuidLightning.checkNetwork=1&auraXhr=true. It looks like each request returns the following:

    1. while(1); {actions: [{id: "224;a", state: "ERROR", returnValue: null,...}],...}
      1. actions:[{id: "224;a", state: "ERROR", returnValue: null,...}]
        1. 0:{id: "224;a", state: "ERROR", returnValue: null,...}
          1. error:[{message: "An internal server error has occurred↵Error ID: 425490117-22284 (500961252)"}]
            1. 0:{message: "An internal server error has occurred↵Error ID: 425490117-22284 (500961252)"}
              1. message:"An internal server error has occurred↵Error ID: 425490117-22284 (500961252)"
          2. id:"224;a"
          3. returnValue:null
          4. state:"ERROR"
      2. context:{mode: "PROD", app: "siteforce:communityApp", contextPath: "/community/s/sfsites",...}
        1. app:"siteforce:communityApp"
        2. contextPath:"/community/s/sfsites"
        3. enableAccessChecks:true
        4. fwuid:"H9Yiy9uuE9726-4_PM7fkQ"
        5. globalValueProviders:[{type: "$SObjectType", values: {,...}}, {type: "$Locale",...}, {type: "$Browser",...},...]
          1. 0:{type: "$SObjectType", values: {,...}}
            1. type:"$SObjectType"
            2. values:{,...}
              1. CurrentUser:{isChatterEnabled: true, Email: "[email protected]", Id: "0058000000Fw1C9"}
                1. Email:"[email protected]"
                2. Id:"0058000000Fw1C9"
                3. isChatterEnabled:true
          2. 1:{type: "$Locale",...}
            1. type:"$Locale"
            2. values:{userLocaleLang: "en", userLocaleCountry: "US", language: "en", country: "US", variant: "",...}
              1. country:"US"
              2. currency:"$"
              3. currencyCode:"USD"
              4. currencyFormat:"¤#,##0.00;(¤#,##0.00)"
              5. dateFormat:"MMM d, yyyy"
              6. datetimeFormat:"MMM d, yyyy h:mm:ss a"
              7. decimal:"."
              8. dir:"ltr"
              9. firstDayOfWeek:1
              10. grouping:","
              11. isEasternNameStyle:false
              12. labelForToday:"Today"
              13. langLocale:"en_US"
              14. language:"en"
              15. nameOfMonths:[{fullName: "January", shortName: "Jan"}, {fullName: "February", shortName: "Feb"},...]
                1. 0:{fullName: "January", shortName: "Jan"}
                  1. fullName:"January"
                  2. shortName:"Jan"
                2. 1:{fullName: "February", shortName: "Feb"}
                  1. fullName:"February"
                  2. shortName:"Feb"
                3. 2:{fullName: "March", shortName: "Mar"}
                  1. fullName:"March"
                  2. shortName:"Mar"
                4. 3:{fullName: "April", shortName: "Apr"}
                  1. fullName:"April"
                  2. shortName:"Apr"
                5. 4:{fullName: "May", shortName: "May"}
                  1. fullName:"May"
                  2. shortName:"May"
                6. 5:{fullName: "June", shortName: "Jun"}
                  1. fullName:"June"
                  2. shortName:"Jun"
                7. 6:{fullName: "July", shortName: "Jul"}
                  1. fullName:"July"
                  2. shortName:"Jul"
                8. 7:{fullName: "August", shortName: "Aug"}
                  1. fullName:"August"
                  2. shortName:"Aug"
                9. 8:{fullName: "September", shortName: "Sep"}
                  1. fullName:"September"
                  2. shortName:"Sep"
                10. 9:{fullName: "October", shortName: "Oct"}
                  1. fullName:"October"
                  2. shortName:"Oct"
                11. 10:{fullName: "November", shortName: "Nov"}
                  1. fullName:"November"
                  2. shortName:"Nov"
                12. 11:{fullName: "December", shortName: "Dec"}
                  1. fullName:"December"
                  2. shortName:"Dec"
                13. 12:{fullName: "", shortName: ""}
                  1. fullName:""
                  2. shortName:""
              16. nameOfWeekdays:[{fullName: "Sunday", shortName: "SUN"}, {fullName: "Monday", shortName: "MON"},...]
                1. 0:{fullName: "Sunday", shortName: "SUN"}
                  1. fullName:"Sunday"
                  2. shortName:"SUN"
                2. 1:{fullName: "Monday", shortName: "MON"}
                  1. fullName:"Monday"
                  2. shortName:"MON"
                3. 2:{fullName: "Tuesday", shortName: "TUE"}
                  1. fullName:"Tuesday"
                  2. shortName:"TUE"
                4. 3:{fullName: "Wednesday", shortName: "WED"}
                  1. fullName:"Wednesday"
                  2. shortName:"WED"
                5. 4:{fullName: "Thursday", shortName: "THU"}
                  1. fullName:"Thursday"
                  2. shortName:"THU"
                6. 5:{fullName: "Friday", shortName: "FRI"}
                  1. fullName:"Friday"
                  2. shortName:"FRI"
                7. 6:{fullName: "Saturday", shortName: "SAT"}
                  1. fullName:"Saturday"
                  2. shortName:"SAT"
              17. numberFormat:"#,##0.###"
              18. percentFormat:"#,##0%"
              19. timeFormat:"h:mm:ss a"
              20. timezone:"America/Los_Angeles"
              21. userLocaleCountry:"US"
              22. userLocaleLang:"en"
              23. variant:""
              24. zero:"0"
          3. 2:{type: "$Browser",...}
            1. type:"$Browser"
            2. values:{containerVersion: "", isWEBKIT: true, isIE11: false, formFactor: "DESKTOP", isWindowsTablet: false,...}
              1. S1Features:{isOfflineEnabled: true, isNativePrimingEnabled: true, areOfflineDraftsEnabled: false,...}
                1. areOfflineDraftsEnabled:false
                2. calendarAnythingAllowed:true
                3. forceReloadRecordForInlineEdit:false
                4. homeAssistantCollapseCards:false
                5. isAccountLogoEnabled:false
                6. isAccountSuggestionsEnabled:false
                7. isAiEverywhereEnabled:true
                8. isAsyncSaveEnabled:false
                9. isAuraParallelBootstrapLoadEnabled:true
                10. isEclairAdvancedFeaturesEnabled:false
                11. isEinsteinBuilderEnabled:false
                12. isEinsteinBuilderLicenseEnabled:false
                13. isEinsteinBuilderPrefEnabled:false
                14. isEinsteinBuilderStartedPrefEnabled:false
                15. isEinsteinEverywhereEnabled:false
                16. isEinsteinMsaAcceptedEnabled:false
                17. isEncryptedStorageEnabled:true
                18. isEnhancedTemplatesEnabled:false
                19. isFilesSharingPrivacyEnabled:true
                20. isFlexipageActionSchedulingEnabled:true
                21. isFlexipageDeprecatedRendererEnabled:false
                22. isForceRefreshViewEnabled:false
                23. isLVMInAppBuilderEnabled:true
                24. isLeadScoreSetupV3:false
                25. isLightningConsoleSplitViewEnabled:false
                26. isListViewGroupShareEnabled:true
                27. isMultiUserOrgEnabled:true
                28. isNativePrimingEnabled:true
                29. isOfflineEnabled:true
                30. isOfflineQuickActionDraftsEnabled:false
                31. isPersonAccountsApiLightningEnabled:false
                32. isPersonAccountsEnabled:false
                33. isS1RecordInlineEditEnabled:false
                34. isSFXInlineEditListViewEnabled:true
                35. isSFXLastViewedListEnabled:false
                36. isSFXUrlFormatSupported:false
                37. isSocialInsightsLogoAdmin:false
                38. isTaskListViewsDisabled:false
                39. isTodayPreviewEnabled:false
                40. isUitrkLoggingEnabled:true
                41. lightningTransitionCompleted:false
                42. lightningTransitionLexWelcomeMatPopupSeen:false
                43. orgHasEinsteinInsightsEnabled:false
                44. orgHasLightningLiveAgent:false
                45. orgHasMatchedLeadsEnabled:false
                46. recordChangeCapture:false
                47. sfxRecordPreviewsOff:false
                48. shouldRedirectToLexAndShowWelcomeMat:false
                49. shouldShowEinsteinInsightsHome:false
                50. showTaskInfoPopover:true
                51. useACTRecordLayoutForCustomObjects:false
                52. useACTRecordLayoutForEdit:false
                53. useACTRecordLayoutForStandardObjects:false
                54. useAntiPopcorn:false
                55. useLexiCallbackReturnUrl:true
                56. useLightningLegacyUrl:false
                57. useLightningReportBuilder:false
                58. useNativeScroller:true
                59. useNewReportRunPage:false
                60. useRaptorAlohaPage:false
              2. containerVersion:""
              3. formFactor:"DESKTOP"
              4. isAndroid:false
              5. isBlackBerry:false
              6. isContainer:false
              7. isDesktop:true
              8. isFIREFOX:false
              9. isIE6:false
              10. isIE7:false
              11. isIE8:false
              12. isIE9:false
              13. isIE10:false
              14. isIE11:false
              15. isIOS:false
              16. isIPad:false
              17. isIPhone:false
              18. isOSX:false
              19. isPhone:false
              20. isTablet:false
              21. isWEBKIT:true
              22. isWindowsPhone:false
              23. isWindowsTablet:false
          4. 3:{type: "$SfdcSite", values: {pathPrefix: "/community"}}
            1. type:"$SfdcSite"
            2. values:{pathPrefix: "/community"}
              1. pathPrefix:"/community"
          5. 4:{type: "$ComponentLibrary", values: {isDSC: false}}
            1. type:"$ComponentLibrary"
            2. values:{isDSC: false}
              1. isDSC:false
          6. 5:{type: "$LightningContainer",...}
            1. type:"$LightningContainer"
            2. values:{communityPrefix: "/community", containedContentHost: ""}
              1. communityPrefix:"/community"
              2. containedContentHost:""
          7. 6:{type: "$Global", values: {eswConfigDeveloperName: {writable: true, defaultValue: ""},...}}
            1. type:"$Global"
            2. values:{eswConfigDeveloperName: {writable: true, defaultValue: ""},...}
              1. appContextId:{writable: true, defaultValue: ""}
                1. defaultValue:""
                2. writable:true
              2. dynamicTypeSize:{writable: true, defaultValue: ""}
                1. defaultValue:""
                2. writable:true
              3. eswConfigDeveloperName:{writable: true, defaultValue: ""}
                1. defaultValue:""
                2. writable:true
              4. isVoiceOver:{writable: true, defaultValue: false}
                1. defaultValue:false
                2. writable:true
              5. setupAppContextId:{writable: true, defaultValue: ""}
                1. defaultValue:""
                2. writable:true
              6. srcdoc:{writable: false, defaultValue: false}
                1. defaultValue:false
                2. writable:false
        6. loaded:{[email protected]://siteforce:communityApp: "CplQAHHeSzLHwfzt5CIKgQ",...}
          1. [email protected]://siteforce:communityApp:"CplQAHHeSzLHwfzt5CIKgQ"
          2. [email protected]://Framework:PicklistInputField:"z9quNNix3a_0k3D9xRg_Ug"
          3. [email protected]://Framework:UrlUtil:"GHaMc9dB67Z-VEtkzGywDg"
          4. [email protected]://LTE:ConferenceEvent:"qi4-iqbv6HxIiE9NCP-iSA"
          5. [email protected]://LTE:EventMainView:"0iM-jKYreNiPF6aovJbf8w"
          6. [email protected]://LTE:EventOverview:"mRk6YFQDN9UIvBbT2DFQ5A"
          7. [email protected]://LTE:EventRegistrationWrapper:"ZEIUSRj1QNab7LbYKkocOw"
          8. [email protected]://LTE:EventWrapper:"FF3dWPMdsemApxco5Nwstw"
          9. [email protected]://LTE:ManageMyRegistration:"pv_-5fHqlfKx_j3Wc-vNpg"
          10. [email protected]://LTE:RegistrationProcessStep:"xHt9loxCrjNwXnFYCxHU6w"
        7. ls:1
        8. mna:{lightning: "interop"}
          1. lightning:"interop"
        9. mode:"PROD"
        10. pathPrefix:"/community"
        11. services:["markup://lightning:configProvider", "markup://force:wireServiceSfdc"]
          1. 0:"markup://lightning:configProvider"
          2. 1:"markup://force:wireServiceSfdc"
      3. perfSummary:{version: "core", request: 76, actions: {224;a: {total: 20, db: 5}}, actionsTotal: 20, overhead: 0}
        1. actions:{224;a: {total: 20, db: 5}}
          1. 224;a:{total: 20, db: 5}
            1. db:5
            2. total:20
        2. actionsTotal:20
        3. overhead:0
        4. request:76
        5. version:"core"

    It looks to me that this gatherer.js script is having trouble connecting properly. Am I reading this correctly?

  • Mark DeSimone
    Mark DeSimone 🛠️ 
    edited August 27, 2018
    Hi Eulogio. I am not familiar with the purpose of gatherer.js myself, but I have a Lightning Community set up in one of my orgs. I can see errors when using SVG icons (see screenshot below) but this is not breaking my setup. 

    It sounds like there is another relevant piece to the puzzle that we haven't identified yet. Are you able to try using a different Skuid page in this community, perhaps starting with the simplest possible? See if that loads as expected. If so, add things in little by little until your test page resembles the affected page, to see if you can identify what is causing the issue. 

    Or an alternate method would be to comment out certain elements of your page XML one by one to see if you can determine which one affects whether the page loads. And, if you're comfortable sharing the page XML here, I can see if it causes similar issues in my org (I'll have to remove custom fields and objects).
  • Eulogio Gallo
    edited August 27, 2018
    Thanks for the response Mark. I created a Skuid page with only a title, and this will not load in my Community. I've tried logging in as a standard user and as a community user and neither has worked for me. Here is a screenshot of what I'm seeing:

  • Mark DeSimone
    Mark DeSimone 🛠️ 
    edited December 17, 2018
    Hi Eulogio, I wanted to close the loop on this issue in the community. What do you suppose finally fixed the issue for you? Our recommendations were to 1) reset your Chrome profile, 2) disable your extensions to see which one might be interfering and 3) make sure Chrome is up to date.
  • Eulogio Gallo
    edited December 17, 2018
    It was definitely the Chrome profile. When I used a browser that didn't have my specific profile it worked fine. There must have been some extension tied to my profile that was causing the issue. Thanks for all of your support on this.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!