Safari Unable to Open Tabs

Andrew OttaruAndrew Ottaru Member
edited February 5 in Problems
I have one user that is not able to open any tab in Skuid, when they click to open the tab, the are getting the error message "Too many redirects occurred trying to open ..." Please see the attached image
image

Comments

  • edited October 2019
    I’ve been getting this too. Works fine in mobile chrome on IOS.
  • Andrew OttaruAndrew Ottaru Member
    edited January 2018
    Chrome is working well for them as well but not Safari on Mac or IPad. Thank you
  • Greg JohnsonGreg Johnson Member
    edited February 2018
    This has just started happening to me also - has Safari become more limiting on the number of redirects before it gives up?  All Skuid pages are inaccessible now.
  • edited October 2019
    Still happening to me. If I navigate directly to the skuid preview page url, however, it will load the page.
  • rslackrslack Member
    edited February 5
    This is happening to my users with Millau 11.0.5
  • Mark DeSimoneMark DeSimone Skuid Mod 🛠️ 
    edited February 4
    Hi Andrew, Rich, Raymond and Greg,

    Have you tried clearing cache for the affected page? I am wondering if the cache for the page has outdated redirect information, as described here: https://support.apple.com/en-us/HT203370 You might also be able to try 'private browsing mode' in Safari to circumvent any cached info for your Skuid pages, to see if it's a factor. 
  • Greg JohnsonGreg Johnson Member
    edited April 2018
    Clearing the cache worked for me.  This seems to happen periodically.
  • Mark DeSimoneMark DeSimone Skuid Mod 🛠️ 
    edited February 4
    Greg, thanks for closing the loop. It will be interesting to hear from Andrew Rich or Raymond what effect is seen wehn clearing browser cache or testing private browsing in Safari.
  • Greg JohnsonGreg Johnson Member
    edited February 4
    I should be more explicit.  Clearing the cache worked in initially, but on the second page opening, I got the same message again.  For now, I have to use Chrome (or Safari in a private browser mode).  
  • edited October 2019
    I tried safari again for the first time in a while and it works in regular mode an Private for me now without clearing the cache. I logged out and back in a couple of times to see if it worked and it worked fine each time. If it stops working again, I’ll report it here. I have iPhone 7 Plus on newest IOS.
  • Mark DeSimoneMark DeSimone Skuid Mod 🛠️ 
    edited April 2018
    Thank you for clarifying, Greg. Which version of Skuid and which version of Safari are you using when you see the error? This conversation was opened in January, so to zero in on a root cause, it will be helpful to understand when things changed and if there was a change to your environment (i.e. Salesforce version, Skuid version, or Safari version) that coincides with the issue's first occurrence. 

  • Greg JohnsonGreg Johnson Member
    edited April 2018
    I'm using Safari: Version 11.0.3 (13604.5.6)
    Skuid - 11.0.5

    I've noticed that this is now impacting our configure-price-quote plugin (Salesforce CPQ, formerly Steelbrick CPQ).  Looks like lots of SF apps are going to cause this hiccups.
  • Mark DeSimoneMark DeSimone Skuid Mod 🛠️ 
    edited February 4
    Greg, is this Safari on Mac, or iOS? I've found this knowledge article from Salesforce that sounds very relevant. 

    https://help.salesforce.com/articleView?id=000269462&language=en_US&type=1

    If this is affecting non-Skuid plugins as well, it sounds like it might be more related to interoperability between Salesforce and Safari. 

    Here is another link that seems related - it sounds like this has come up in the recent past for others. https://success.salesforce.com/answers?id=9063A000000e1jvQAA 

    Are you able to safely try any of the recommendations in either of these links?
  • Greg JohnsonGreg Johnson Member
    edited April 2018
    I did the salesforce.com cache clearance followed the force quit (I'd not done the force quit first time I tried) and now it seems to be better again.  What a PITA.  Thanks Skuid folks for helping!
  • Greg JohnsonGreg Johnson Member
    edited April 2018
    Oh, and yes it was on macOS, not iOS.
  • Andrew OttaruAndrew Ottaru Member
    edited April 2018
    My apologies for the late reply on this, we went through the following steps to resolve the issue:
    1. Go to the Safari menu in the upper left corner of your browser. 
    2. Select Preferences. Select Privacy. Under Cookies and website data, select Details (or Manage Website Data). 
    3. Search for Salesforce. 
    4. Select Remove. 
    5. Select Remove Now. 
    6. After the Salesforce website data has been deleted, force-quit Safari and try logging in to Salesforce again.
    I hope this helps. Thank you
Sign In or Register to comment.