Is it hard to remove table settings icon

David ForderDavid Forder ✭✭
edited June 25 in Questions
It seems to push the table down a page and I would much rather remove it all together. I can hide it in css but that doesnt fix the spacing


  • edited May 2018
    It sounds like you want to have a table with no elements above the table header.  You just need to uncheck the box 'Allow Users to Show/Hide Column' for every field in your table and then uncheck the box 'Show Search Box' under the table's Filter & Search tab-> Search Properties.  Here is sample XML that demos this for Contacts.


    <skuidpage unsavedchangeswarning="yes" personalizationmode="server" useviewportmeta="true" showsidebar="true" showheader="true" tabtooverride="Contact">    <models>
            <model id="Contact" limit="100" query="true" createrowifnonefound="false" datasourcetype="salesforce" datasource="salesforce" sobject="Contact">
                    <field id="FirstName"/>
                    <field id="LastName"/>
                    <field id="CreatedDate"/>
            <pagetitle model="Contact" uniqueid="sk-1OB6y--94">
                    <action type="savecancel"/>
            <skootable showconditions="true" showsavecancel="false" searchmethod="server" searchbox="false" showexportbuttons="false" pagesize="10" createrecords="true" model="Contact" mode="read" allowcolumnreordering="false" uniqueid="sk-1OB6y--95" emptysearchbehavior="query">
                    <field id="FirstName" hideable="false" allowordering="true" uniqueid="fi-1OB672-373" valuehalign="" type="" showbydefault="false"/>
                    <field id="LastName" hideable="false" allowordering="true" uniqueid="fi-1OB672-374" valuehalign="" type="" showbydefault="false"/>
                    <field id="CreatedDate" hideable="false" allowordering="true" uniqueid="fi-1OB672-375" valuehalign="" type="" showbydefault="false"/>
                    <action type="edit"/>
                    <action type="delete"/>
                <massactions usefirstitemasdefault="true">
                    <action type="massupdate"/>
                    <action type="massdelete"/>
                    <view type="standard"/>
            <styleitem type="background" bgtype="none"/>
  • David ForderDavid Forder ✭✭
    edited May 2018
    Thats it.. I missed the 'Allow Users to Show/Hide Column" flag ... Thanks )
  • edited February 2017
    I would have just used css and made the display value "none"
Sign In or Register to comment.