Is it hard to remove table settings icon

David Forder
David Forder ✭✭✭✭
edited June 25, 2020 in Questions
It seems to push the table down a page and I would much rather remove it all together. I can hide it in css but that doesnt fix the spacing

Comments

  • Bill McCullough
    Bill McCullough 💎💎
    edited May 15, 2018
    David,
    It sounds like you want to have a table with no elements above the table header.  You just need to uncheck the box 'Allow Users to Show/Hide Column' for every field in your table and then uncheck the box 'Show Search Box' under the table's Filter & Search tab-> Search Properties.  Here is sample XML that demos this for Contacts.

    Thanks,

    Bill
    <skuidpage unsavedchangeswarning="yes" personalizationmode="server" useviewportmeta="true" showsidebar="true" showheader="true" tabtooverride="Contact">    <models>
            <model id="Contact" limit="100" query="true" createrowifnonefound="false" datasourcetype="salesforce" datasource="salesforce" sobject="Contact">
                <fields>
                    <field id="FirstName"/>
                    <field id="LastName"/>
                    <field id="CreatedDate"/>
                </fields>
                <conditions/>
                <actions/>
            </model>
        </models>
        <components>
            <pagetitle model="Contact" uniqueid="sk-1OB6y--94">
                <maintitle>
                    <template>{{Model.labelPlural}}</template>
                </maintitle>
                <subtitle>
                    <template>Home</template>
                </subtitle>
                <actions>
                    <action type="savecancel"/>
                </actions>
            </pagetitle>
            <skootable showconditions="true" showsavecancel="false" searchmethod="server" searchbox="false" showexportbuttons="false" pagesize="10" createrecords="true" model="Contact" mode="read" allowcolumnreordering="false" uniqueid="sk-1OB6y--95" emptysearchbehavior="query">
                <fields>
                    <field id="FirstName" hideable="false" allowordering="true" uniqueid="fi-1OB672-373" valuehalign="" type="" showbydefault="false"/>
                    <field id="LastName" hideable="false" allowordering="true" uniqueid="fi-1OB672-374" valuehalign="" type="" showbydefault="false"/>
                    <field id="CreatedDate" hideable="false" allowordering="true" uniqueid="fi-1OB672-375" valuehalign="" type="" showbydefault="false"/>
                </fields>
                <rowactions>
                    <action type="edit"/>
                    <action type="delete"/>
                </rowactions>
                <massactions usefirstitemasdefault="true">
                    <action type="massupdate"/>
                    <action type="massdelete"/>
                </massactions>
                <views>
                    <view type="standard"/>
                </views>
                <searchfields/>
            </skootable>
        </components>
        <resources>
            <labels/>
            <css/>
            <javascript/>
        </resources>
        <styles>
            <styleitem type="background" bgtype="none"/>
        </styles>
    </skuidpage>
  • David Forder
    David Forder ✭✭✭✭
    edited May 15, 2018
    Thats it.. I missed the 'Allow Users to Show/Hide Column" flag ... Thanks )
  • Matt Small
    edited February 19, 2017
    I would have just used css and made the display value "none"
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!