Page include not working with Brooklyn upgrade

edited September 30, 2019 in Questions
The page doesn't load since updating when using id={{$}} as a query string.

Any ideas of how to correct this?


  • edited March 2, 2017
    Looks like a bug, but try using triple brackets: {{{$}}}
  • edited January 11, 2017
    No, that doesn't work.  Do you know if there will be a fix for this shortly?

  • edited January 25, 2017
    Hi Team,

    I am facing this issue after upgrading my skuid package to Iteration 3.

  • edited March 25, 2019
    I am facing the same issue even using 9.3.3

  • edited January 25, 2017
    Our sandboxes were upgraded this morning without us doing anything and we are now experiencing the same issue on 9.3.3
  • edited January 25, 2017
    I am having this problem as well. I did not update to 9.3 but somehow last night all of my sandbox environments automatically updated from 8.15.8 to 9.3 and now all my page includes are broken.  I tried to revert back to 8.15.8 but was getting the failed install message as my sandboxes are already updated to Spring '17.
  • edited January 27, 2017

    Is there any update on when can this be fixed please?
  • Karen WaldschmittKaren Waldschmitt 🛠️ 
    edited March 2, 2017
    Hi Skuid Community~

    This may have been fixed in Brooklyn Iteration 4 by [SKUID-2866] which is now available from the Skuid Releases page. Can you try upgrading and see if it fixes the issue or not? As a reminder, Salesforce does NOT allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. We also recommend that you update out of date themes when you upgrade.

    Please let us know if upgrading does not fix the problem and we will investigate further ... 

  • edited January 30, 2017
    Hi Karen,
    I don't think the issue is still addressed. I have upgraded to 9.3.4 and the issue still exists for me.  Need quick resolution to this.

    Best Regards,
    Amit !
  • edited January 30, 2017
    Can you give a method for us to be able to recreate the problem?
  • edited January 31, 2017
    Hey Stephen, sorry the formatting is going to be destroyed but I have pasted the snippet below.  This runs without issue after the page has loaded.

    <jsitem location="inline" name="renderAsReadOnly" cachelocation="false" url="">var $ = skuid.$;
    $(function() {
        var opportunity = skuid.model.getModel('Opportunity').getFirstRow(),
            isClosed = opportunity.IsClosed;
        var renderFieldEditor = function() {
        var pageTitle = $('#pageTitle');
            var editor ='object').editor;
        var fieldEditor = $('.nx-basicfieldeditor').data('object');
        if(isClosed === true) {
                displayMessage(editor, 'This opportunity has been closed', '');
        var renderAsReadOnly = function(fieldEditor) {
            fieldEditor.mode = 'readonly'; 
        var displayMessage = function(editor, message, severity) {
                      message: message
                      ,severity: severity.toUpperCase()
            $(".nx-messages *").off("click");
            $(".nx-messages *").css("cursor", "default");
  • edited January 31, 2017
    Replace this line:

    $(function() {

    with this:

    $(".nx-page").one("pageload", function() {
  • edited February 1, 2017
    Hey Zach, that worked for the above example.  One other snippet we use in many places which also breaks on quite a few pages - : 

    skuid.snippet.registerSnippet('showVIPAlerts',function(field,value) {  var $ = skuid.$;

      var noteModel = skuid.model.getModel('Notes');

      var renderFieldEditor = function() {
        var pageTitle = $('#notesTitle');
        var editor ='object').editor;

        if( > 0) {
          for(var i = 0; i <; i++) {
            var row =[i],
            parentType = '',
            createdDateFormatted = skuid.time.makeFormattedDate(row.CreatedDate);
            switch(row.Parent.Type) {
              case 'CustomObject__c':
              parentType = 'Custom Object';
              case 'OtherCustomObject__c':
              parentType = 'Other Custom Object';
              parentType = row.Parent.Type;
            parentTypeInfo = ' (' + parentType + ': ' + row.Parent.Name + ')';
            displayMessage(editor, createdDateFormatted + ' ' + row.Body + parentTypeInfo + ' - ' + row.CreatedBy.Name, 'warning');

      function displayMessage(editor, message, severity) {
          message: message,
          severity: severity.toUpperCase()

        $(".nx-warning").css("cursor", "default");

  • edited February 13, 2017
    Any further update on this?
  • Amy DewaalAmy Dewaal 💎
    edited May 23, 2018

    Are you still on 9.3.3? Have you tried updating to 9.3.4? 

    Sorry this is still an issue for you!
  • edited February 15, 2017
    Hi Amy,

    Yes, we have updated two of our sandboxes to 9.3.4 and are still having this issue.  I will continue to look at options on our end since we cannot upgrade our production instance until we have a workaround.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!