External object name Not Acceptable for Informatica odata source

George WuGeorge Wu Member
edited May 2018 in Problems
I am trying to setup skuid to use Odata1-3 to connect to a Informatica realtime odata source that is connected to SQL server. When selecting the External Object Name, I get the Not Acceptable error message. I used the same Informatica end point with Lightning Connect and it was able to retrieve and sync all my tables. https://ps1w2.rt.informaticacloud.com/active-bpel/odata/v4/JDBC-xxxxx My initial guess is that maybe Skuid is not compatible with Odata V4?

Comments

  • Amy DewaalAmy Dewaal Member, Skuad ✭✭
    edited May 2018
    George,

    What version of Skuid are you on? As of the Brooklyn GA release, Skuid should work with Odata 4. 

    Thanks!
    Amy
  • George WuGeorge Wu Member
    edited December 2016
    I am using 8.15.8, Rockaway Iteration 10, what was installed from appexchange.
  • Amy DewaalAmy Dewaal Member, Skuad ✭✭
    edited May 2018
    George,

    That's probably the issue then! Before the Brooklyn release Skuid only supported Odata 1-3. If you'd like to connect through Odata 4 try updating to a Brooklyn release. Brooklyn Iteration 1.1 is available at Skuid's Releases page. As a reminder, Salesforce does not allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. 

    Thanks!
    Amy
  • George WuGeorge Wu Member
    edited December 2016
    Hi Amy, I installed Brooklyn Iteration 1.1. When selecting External Object Name, the icon in the field just keeps spinning. I have no problem if I use the Northwind data source. Thanks, George
  • Amy DewaalAmy Dewaal Member, Skuad ✭✭
    edited May 2018
    George,

    I just learned you also need a custom configuration in the data source of odata-version: 4.0 for the connection to work:

    image

    Does adding this help?

    Thanks!
    Amy
  • George WuGeorge Wu Member
    edited December 2016
    Yes. The setting solved the problem. Thanks!
Sign In or Register to comment.