"Submit" Button on Approval Process Flows

edited March 2018 in Problems
We now have a problem when a user hits a submit button (custom button with URL on SKUID page) for an approval flow.  This messages shows up-
We need to confirm that your request is valid. Please repeat your last action.
I've never seen that before.  Has anyone encountered this?

Answers

  • JD BellJD Bell ✭✭
    edited March 2018
    Can you please describe the custom button? Do you mean that you created an <input type="submit"> element on the page? How is the URL specified? Do you also create a custom <form> element?
  • edited October 2015


    Sorry, here's the button that I have-

    <actions defaultlabel="Global Actions" defaulticon="ui-silk-wand" usefirstitemasdefault="true">
                            <action type="redirect" label="Submit for Approval" url="/p/process/Submit?id={{$Param.id}}&amp;retURL=%2F{{$Param.id}}" icon="ui-silk-lock-go" window="self"/>
                            <action type="redirect" label="Approve / Reject" url="/p/process/ProcessInstanceWorkitemWizardStageManager?id={{#$Model.Item.data}}{{Id}}{{/$Model.Item.data}}" icon="ui-silk-thumb-up" window="self"/>
     </actions>


    It worked on Friday when I left the office and now it doesn't.


  • edited December 2016
    Colby,

    We had the same problem. With the SF winter 16 release this button now needs a confirmation token. The way I got around this was with Robs solution on this post. Hope this helps!
  • edited October 2015

    Thanks, Tami! I got that to work.

  • Rob HatchRob Hatch 🛠️ 
    edited September 2016
    We are also taking a look at the new approval process requirements and evaluating whether Skuid can call the approval actions directly. 
  • Rob HatchRob Hatch 🛠️ 
    edited September 2016
    I've added another option to the post Tami links to above.  Another way to fix this... 
Sign In or Register to comment.