Can't see html editor in home page

jdbuergerjdbuerger ✭✭
edited October 2017 in Problems
I'm trying to reclaim my home page using Skuid. Everything I've done so far (lists and detail pages) has worked great but I can't get my Salesforce instance to work the same as your tutorial on the home page. image When I insert the iframe code into the html editor, it just shows the code rather than instituting an iframe. I presume the issue is that I need to write in html and not use the WYSIWYG editor that Salesforce gives me ... but I have no idea on how to turn off that WYSIWYG editor (pictured). image Any ideas?

Comments

  • Rob HatchRob Hatch 💎💎💎
    edited September 2016
    We actually need to rework that tutorial.  In Summer 14,  Salesforce actually removed the HTML editor for home page components, which makes it impossible to insert the code as we described in the tutorial . 

    Salesforce now provides a visualforce area - which you can use to wrap a skuid page.   Look at this tutorial about connecting a Skuid page to a VisualForce page.  Then add the Visualforce page to your home page layout. 

    Hope that helps...  
  • jdbuergerjdbuerger ✭✭
    edited October 2017
    Can you give me a specific link for that tutorial since this is for the home page and not a tab or details page and I don't know how to write the VisualForce page programming for that particular instance.
  • Rob HatchRob Hatch 💎💎💎
    edited September 2016
    You are not alone.  Overrides are a pretty complicated area - with lots of alternatives and possibilities for problems. 

    I believe you can use the very simplest VF syntax possible,  because you are just calling the skuid page and don't need to call any controllers.   Here is the VF page code you need to use (and adust) 
     Show specific page with no controller

    <apex:page showHeader="true" sidebar="false" readonly="true" docType="html-5.0"


        <skuid:page page="MyOpenTasks" />
    </apex:page>        title="
    Replace the "MyOpenTasks" with your skuid page name.  And probably remove the title, and change showHeader and Sidebar properties to false. 

    I hope that works for you. 


  • edited August 2014
    We've updated the Reclaim the Salesforce Home Page instructions to reflect the changes in the Salesforce Summer '14 release.

    The tutorial now explains how to add a Visualforce page that wraps around a Skuid page.

    Rob's VF code is correct, but here's a tidied up version for those who are interested:
    <apex:page showHeader="true" sidebar="false"> 
    <skuid:page page="HomePageWideArea"/>
    </apex:page>
    Replace HomePageWideArea with the name of your Skuid page and you should be good to go!

    -Josh

  • jdbuergerjdbuerger ✭✭
    edited October 2017
    This is working great except that I cannot get rid of the sidebar. Even when I click off all the components possible, it shows a Recycle bin. image
  • Rob HatchRob Hatch 💎💎💎
    edited September 2016
    I think this is a basic limitation of the salesforce home page.  They don't allow you to completely get rid of the sidebar. 
    However,  in the "User Interface" settings you can enable the sidebar to be collapsable.  Go to Setup - Build - Customize - User Interface  (very last one in the customize list).  In that page look for "Sidebar" settings and make sure collapsible sidebar is checked. 

    The good thing about this setting is that it is remembered. So if you hide the sidebar today,  it stays hidden tomorrow.. 
  • edited March 2015
    Rob,

    I see a solution for a sidebar. However, there are still see two more issues..

    1) Top level chatter -- I think this is unnecessary as I have already create "Chatter" tab in a SKUID page below

    2) Second, for some reason "Home Page" built with SKUID takes has longer delay in rendering compared to all other pages.

    Please let me know any solution for that!

    Thanks,
    Unmesh
  • Rob HatchRob Hatch 💎💎💎
    edited September 2016
    Unmesh,  unfortunately I see no solution for either problem. 

    1. Now that Skuid is in a VF page,  it is rendered in a IFrame and has no access to manipulate the DOM outside of itslelf.  The way we were able to hide the chatter component before was to add some CSS to the skuid page that affecte the parent page.  That strategy is no longer possible. 

    2. Load times.  The fact that we are in an iFrame may make things load slower, as the full Salesforce page has to load before it calls the iFrame contents (when the SKuid page starts loading).  I don't think we can do anything about that. 

    Sorry...
Sign In or Register to comment.