Dropping Custom Field into URL on Template Component

edited March 7, 2017 in Questions
This should be an easy one.  

I have a template field in a field editor component and I am trying to do a simple link to a Salesforce report where I am passing in a field value.  However, it looks like Skuid forces the custom field to be displayed.  

My setup.  You can see my template link is: 
<a href="https://my.salesforce.com/00O50000003v1Ir?pv0={{Household__c}}">Report</a>;


But the result is this:





What I want is the just the word "Report".  Why is it displaying the Household__c value?? I have tried enabling and disabling 'Allow HTML'.  Same behavior.

What do I need to do to my template link so that it drops in the custom field into the URL and only displays the proper text?

Thanks!







Comments

  • J.J. 💎
    edited March 7, 2017
    Peter,

    Try using a triple curly brace around that Household__c merge:
    {{{Household__c}}}  
  • edited January 27, 2017
    Thanks!  I knew it was really easy!  Thanks for the fast response. 
  • J.J. 💎
    edited January 30, 2018
    No problem! Just for fun (and in case anyone else finds this thread looking for info on Skuid merge syntax), here are a couple of documentation links:
    1. Skuid Template Syntax - http://help.skuidify.com/m/11720/l/216661-skuid-template-syntax
    2. Global Merge Variables / Functions - http://help.skuidify.com/m/11720/l/187263-global-merge-variables-functions
  • edited January 27, 2017
    Thanks for the resources.  I'll review these closer.  One more related question, I just added the target="_blank" and it's working great but when I get back to the Skuid page tab I see this blank pop-up.  What's that and how do I get rid of it?


  • J.J. 💎
    edited March 7, 2017
    That's a new one to me. This is on the page builder? Would you mind posting your page XML (look for the View/Edit XML link in the bottom right corner)?
  • edited January 27, 2017
    Is there a way I can send it to you privately?  Otherwise I need to run through the code and mask a bunch of labels.
  • J.J. 💎
    edited March 7, 2017
    Certainly, though you are welcome to mask the labels anyway. Is emailing [email protected] private enough?
  • edited January 27, 2017
    Sent!
  • Zach McElrathZach McElrath Principal Software Engineer Chattanooga, TN 💎💎💎
    edited March 2, 2017
    Peter, try marking "Read-Only" on your Template field. That should disable this popup.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!