13.0.11 Guest User Access using stored credentials

«1

Comments

  • Dave
    Dave 💎
    edited January 18, 2021

    HI Anna,

    Quick question. I had tested the guest access using stored credentials (declarative way with SF as a DSO) in a sandbox with skuid version 12.2.19, and as mentioned above, we had issues with the file upload but everything else was working fine.

    We just updated the same sandbox to skuid version 13.0.11 and it seems the setup no longer works and the guest user no longer can access page...

    Showing this instead:

    Authorization Required


    You must first log in or register before accessing this page.

    If you have forgotten your password, click Forgot Password to reset it.



    Is there any additional changes that could have caused this?


    Let me know

    Thank you

  • Interesting. Have you made sure the guest user has all the updated permissions on the SF side to your public site home page and the objects on it?

    Double check that the guest user profile has read permissions for the Skuid page object and any other objects on the page not accessed via your external data source. Also confirm that you've give the guest user access via sharing rule to the specific Skuid page record and any other records on the page not accessed via your external data source.

    See this KB article: Troubleshooting: Guest User Access after Winter '21

  • HI Anna,

    I can confirm the following:

    The guest user profile has access to skuid page

    The guest user has access to record i'm testing on

    That skuid page only use SF as a DSO for all modals

    At this point not sure what else can be the issue.


    Let me know

    Thank you!

  • Interesting... Can you also confirm that the guest user has a Skuid license?

  • It's in Sandbox so no license assignment option available that i can see

  • @Anna Wiersema let me know if you want me to grant access to this sandbox, so we can get to bottom of this.

    If not any thing to help me move forward would be appreciated

    Thx

  • @Dave Is this org on Spring '21 or Winter '21?

  • @Anna Wiersema

    Hey Anna, any ideas on what can we done for this?

    As we are getting closer to limit and we need to implement this solution in production, before then.

    Let me know

    Thank you

  • Hey @Dave

    1. To be 100% clear, you've created sharing rules to share the Skuid page record and the record your testing on with the guest user?
    2. If you can verify that the user has permission to see the specific Skuid page record, I recommend running some tests to help isolate the cause of the error. You can comment out different parts of your page in the XML and seeing if the permissions error goes away. Then you can isolate which aspects of the page are causing the error.
    3. For curiosity's sake, did you rebuild your external SF connection in this org after upgrading, or did you upgrade an org with the existing external connection?


  • hey @Anna Wiersema ,

    1. 100% sure. test account i'm using has been shared to the guest user, same with Skuid page. I have a public group named skuid with the guest user h
    2. ere's record shared to group and guest userere's record shared to that groupnd here's skuid page , being shared as well .the user being used right now for testing in sandbox is mine, which is full admin license and has access to all, with no exceptions. When i preview page as my user all works fine..I upgraded org with an existing external connectionet me knowhank you!
  • here's record shared to that group


    and here's skuid page, being shared as well


    2. the user being used right now for testing in sandbox is mine, which is a full admin license and has access to all, with no exceptions. When I preview page as my user all works fine.

    3.I upgraded org with an existing external connection



    Let me know



    Thank you!

  • Rob Hatch
    Rob Hatch 🛠️ 
    edited January 28, 2021

    I think you have not used the Guest User Sharing method to grant access to the Skuid Page. I don't believe that Manual Sharing will be enough to grant read access to the Skuid Page Record.

    I have rules set up below for the two public site access profiles in my org. (One for a Force.com site, and the second for a public Lightning community)


    I configure this on the Sharing Settings page....

  • @Rob Hatch thank you did that change, but still same issue


  • Can someone point me to instructions for setting up guest user access using stored credentials?

  • @AnnaO @Rob Clough

    Hey guys we are getting closer to the forced change, anything else i can try, do you guys want access to sandbox?

    Let me know

    Thx

  • @Anna Wiersema @Rob Hatch

    Hey guys we are getting closer to the forced change date limit, anything else i can try, do you guys want access to sandbox?

    Let me know

    Thx

  • @Anna Wiersema

    Hey Guys In the meantime I was waiting for suggestions, I actually created a new Sandbox and recreated whole process and it seems to work fine now!

    I guess updating from 12.2.19, to 13.0.11 broke something...

    In case makes a difference the new sandbox is on Skuid version: 13.0.12

    Now to try on prod and hope all goes well :)


    Thank you

  • Super glad you were successful. Sorry we haven't had the bandwidth to do a lot of deep debugging of your configuration. It is complicated in the SFDC side.

    And finally - we do hope the prod implementation is successful.

    Would love to see your public site.. (I always love seeing Skuid in the wild)

  • @Rob Hatch

    Funny i was just typing this when I saw your message.

    Everything went perfectly in sandbox , but now been trying since yesterday to do exact same setting sin prod, 3 times now and always the same issue: whenever I try to use the new externalSF DSO i get authentication failed.

    This is just driving me crazy , as i double and triple check everything is exactly the same as in Sandbox.

    Only 1 thing i noticed different, is when i create the DSO, it tries to create the Authentication providers on it's own, and i see a an error message that goes away too quickly for me to read completely and copy it , but an error creating remote setting basically.

    I tried creating it manually, that did not work, So i tried creating the authentication provider myself (not from the new DSO setup) and this time it creates the remote setting properly it seems, but still same issue.

    And yes I would love to show you the public site anytime!

    maybe we can have a quick screenshare so we can do both same time?

    Let me know


  • @Anna Wiersema @Rob Hatch

    Hey Guys is anyone else experiencing the same issue setting it up in prod?

    I'm starting to panic, we are 3 days away from Spring release and it still not working for me at all in prod

    please help me

    Thx

  • @Anna Wiersema @Rob Hatch @Skuid IT @skuid

    Hey, me again after spending the whole day trying to troubleshoot this, I was able to pinpoint exact issue, but no clue how to fix it, as it may be a backend issue, according to my dev.

    The Authentication issue happens only in production when i use the Auth Grant Type as Resource Owner Password Credentials. If i use Authorization code, the skuid page can connect to this DSO but unfortunately this doe snot fix the reason we are doing this, guest user (with stored credentials)

    Hope this can help you guys help me with this urgent issue pls

    Thx

  • As well forgot to mention we are on latest skuid release (13.0.13)

    And that i tried the stored credentials with different users, even me as admin.. and still failing to authenticate

  • Hi Guys,

    I was finally able to fix this issue, and the problem is incomplete documentation.

    As a desperate last attempt today, I tried adding the SF user Security Token after password in the stored credentials and that fixed the issue in production. This is not required in sandbox

    Nowhere in the documentation is that point mentioned. That just cost me almost 3 days of losing hair :(

  • Ah, yep. Sorry, @Dave ! I managed to discover that last week when I was first setting up, but I didn't make the connection to the problem you were having. :(


    Definitely needs a documentation update!

  • @Matt Sones @skuid @Rob Hatch @Anna Wiersema

    Hey Guys , all was working fine on Friday and now over the weekend SF pushed the new Release and now all of a sudden the External Data source won't work at all. I tried even with authorization code and stored credentials, but cannot connect to data source

    Is anyone having similar issues?

  • Anna Wiersema
    Anna Wiersema 🛠️ 
    edited February 15, 2021

    @Dave what a bummer!

    1. Is it still working in your Spring '21 Sandbox?
    2. Can you look at status.salesforce.com for both of your instances and let us know which patch of Spring '21 each is on?
    3. If your Sandbox site is no longer working, do you happen to remember which patch it was on when it worked?
    4. Is the external data source not working just in the public facing site, or also when you're logged into Salesforce and previewing the Skuid page?
  • @Anna Wiersema It can connect to the External Data Source in Sandbox with no issue, but site page gives same error even from sandbox. All was working perfectly fine last week on both environment (on production it was running live with external SF DSO since thursday)


    Any way you can assist me please, this is a huge issue and affecting us big time already?

  • Hi @Dave,

    • What is the error message you are seeing on your site?
    • Can you look at status.salesforce.com for both of your instances and let us know which patch of Spring '21 each is on?
    • Do you know what Spring '21 patch your Sandbox was on when it was working?


    On our end I've verified that this use case works in Spring '21. The use cases I checked were public Force.com Sites on

    1. v2 - Boston (13.0.14) - Spring '21 Patch 8.5
    2. v1 - Boston (13.0.8) - Spring '21 Patch 8.6


Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!