Authorize and Token Endpoint URL are not working

I have created a salesforce connected app and using that to call in Authentication provider. When I select Salesforce as provider type getting below as default:

Authorize End point url: https://<MyDomain>.my.salesforce.com/services/oauth2/authorize

Token Endpoint url: https://<My Domain>.my.salesforce.com/services/oauth2/token

After replacing My domain with salesforce domain if i try to call the datasource then getting error as "Unable to authenticate to data source, login has been cancelled".

Please help me with how to provide appropriate Authorize and token end point urls

Answers

  • Hi @kavyas

    Have you walked through the documentation on setting up an external data source yet? It's really helpful.

    -------------------------------------------

    Please double check that you've taken the following steps from Set up a Salesforce Data Source:

    To use the Salesforce data source type with Skuid, you’ll need to complete the following three steps for each external org you want to access:

    1. On the external Salesforce org: Create a Salesforce connected app on the external org [this is the source of the Client ID and Client Secret credentials that you will need for your authentication provider]
    2. On Skuid: Create a Salesforce authentication provider that uses the credentials from the connected app created in the external Salesforce org. [sometimes this is set up automatically when you do #3]
    3. On Skuid: Create a Salesforce data source to facilitate a connection to the external Salesforce org.

    Before you start

    • You must have the latest version of Skuid installed in each external Salesforce org you will be accessing.
    • You must have licensed Skuid user credentials for each external Salesforce org you will be accessing. These user credentials must match the credentials used to pull the data; use the same Salesforce/Skuid credentials throughout this process.
    • My Domain must be enabled on any Salesforce Org you will be accessing. While the org’s instance-based URL (e.g. https://na30.salesforce.com/) will technically work, using it is not recommended since this URL is subject to change when Salesforce performs instance migrations. My Domain is free and available on all Salesforce orgs that can run Skuid. Configure your org’s My Domain settings by navigating to Setup > Domain Management > My Domain. To learn more, see Salesforce’s My Domain documentation.


  • Hi @"Anna Wiersema" ,

    Thanks for the replay, i have done the setup as per the above documentations. I have created a connected app in salesforce org also from which im generating client id and client secrete.
    when i try to create new Authentication provider using client id and client secrete from salesforce connected app, i will get below screen
    for Authorize end point and token end point URL, when i try to replace the domain name and try to connect to generate the token, im getting error as i mentioned above.

    In documentation i didnt find any information regarding setting up Authorize and token end point URLs, can you please help me on this.
  • Hi @kavyas what version of Skuid are you using?

    Did you see the Authorize Endpoint URL & Token Endpoint URL section of the docs on setting up an external Salesforce data source.

  • Hi @Anna Wiersema ,


    We are using the skuid version 12.2.9. And i had configured  Authorize Endpoint URL & Token Endpoint URL as per the above link.

    I had configured Authentication provider and used the same in Data source with the type REST. Added the screenshot below:

    Now when i try to fetch the data source details into skuid page which I created, I'm not getting the token generating automatically and hence the fields details i'm not able to fetch.

    Could you please help me on this part. Below is the error which i'm getting while fetching fields from REST API:

    Error connecting to REST Data Source at URL "URL": Whitelabel Error PageThis application has no explicit mapping for /error, so you are seeing this as a fallback.Fri Feb 05 12:09:01 UTC 2021There was an unexpected error (type=Forbidden, status=403).Access Denied

  • Hi @kavyas ,

    Thanks for providing that information. I need a few more details to know how to best advise you.

    1. What's your end goal? Can you share some more details here?
      1. Are you trying to connect to an another Salesforce org, or the same Salesforce org you're working in?
      2. Do users need to use their own credentials, shared credentials, or another type?
    2. For your Data Source Type, are you using REST or Salesforce? From what you've said it sounds like you're using REST to access Salesforce. As shown in the screenshot below, in Configure - Data Sources, is the type salesforce or REST?

    3. For your authentication provider, which authentication type are you using? (e.g. Salesforce, other, etc.)

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!