Currency Field issue

I am using Salesforce currency field in Skuid form. When I try to type 100k, I am not able to keying char value(k) in the field. After saving the record. When I view the record I am not able to see ',' between the numbers. Like 100,000 instead I am seeing 100000. Am i doing something wrong or this is skuid limitation.

Answers

  • Hi Inba,

    What version of Skuid is installed? Is this happening on a V1 or V2 page?

  • Hi @JustenHollis,

    Thanks for your reply. I have Boston (13.0.5.0) release and V2 page.

  • I'm also not able to use the "k" functionality from Salesforce in V2, I'll ask internally to see why that functionality doesn't exist. For the coma issue can you paste the xml from a simple repro page (that uses standard Salesforce objects) here so I can take a look at it?

  • Hi @JustenHollis,

    Here is the xml code.

    <fields>  

    <field id="Basic_Wage__c" horizontalAlignment="right" uniqueid="fi-Y2k-101093" required="true"/>  

    </fields>

  • @Inba , The currency shortcuts (K,M,B) is actually a known issue and has been reported to our dev team to look at further.

    As for the coma's not showing, I'm unable to reproduce that. It looks like the xml you included above contains a custom object, do you see this issue when you are using standard Salesforce objects? For instance the opportunity object. Can you include all of the XML from a simple repro page with standard Salesforce objects?

  • Hi @JustenHollis,

    Yes, its in Custom object. When i try to input the value directly in Salesforce page i dont have any issues in commas or the $ symbol. I have issue with the skuid page only. My xml has 635 lines can you please guide me where to look for the settings.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!