Action Sequence -> Post to Chatter doesn't appear to load message and group after editing

Made an action sequence to post to chatter when a sponsorship is created. It posts successfully.

But, when you go back to edit the action, the parameters for Message and Target Name or ID aren't being displayed for additional editing. The fields are empty.

If I view the page XML, the field values are in there:

<actionsequence id="610539c4-1e00-4837-8562-51938cc1b5c8" label="Post Sponsorship to Chatter" type="reusable">

<description/>

<actions>

<action type="branch" whenfinished="stop" model="Sponsorship" label="Post Contact Sponsorship">

<formula>{{Sponsorship_Type__c}} = "Contact"</formula>

<iftrueactions>

<action type="datasource-action" datasource="salesforce" actionname="chatterPost">

<inputs>

<input name="text" displaytype="string" value="{{Sponsored_Contact__c}} has a new sponsor {{Sponsor_Account__c}}"/>

<input name="subjectNameOrId" displaytype="string" value="Sponsorship News"/>

<input name="type" displaytype="picklist" value="group"/>

</inputs>

</action>

</iftrueactions>

</action>

<action type="branch" whenfinished="stop" model="Sponsorship" label="Post Account Sponsorship">

<formula>{{Sponsorship_Type__c}}="Account"</formula>

<iftrueactions>

<action type="datasource-action" datasource="salesforce" actionname="chatterPost">

<inputs>

<input name="text" displaytype="string" value="New {{Sponsored_Account__c}} project sponsorship by {{Sponsor_Account__c}}"/>

<input name="subjectNameOrId" displaytype="string" value="Sponsorship News"/>

<input name="type" displaytype="picklist" value="group"/>

</inputs>

</action>

</iftrueactions>

</action>

</actions>

</actionsequence>

Installed Skuid last week, Installed Packages is showing 13.0.5

Just getting back into Skuid and liking it a lot.

Thanks

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!