TypeError: e is null in function loadSkuid

Joan Jackson
Joan Jackson ✭✭
edited September 17, 2020 in Questions

We have licensed skuid users who randomly get this error when they open a Salesforce record containing multiple skuid pages:

There was an erorr rendering Skuid Page component for page [our page name] TypeError: 3 is null.

The Function value in the message is loadSkuid/< Line 166

This web site is not allowing me to post a screen shot of the error message

There are 3 skuid pages on this record detail where the above error is being thrown for each component on many (but not all) page loads.. The skuid lightning component is being used for each skuid table on this page.. The users are in Salesforce lightning and many of them use Firefox rather than Chrome. I use Chrome and never see these errors.

Our skuid version is Spark Update 3, verson 12.4.13. It seems as though these users are getting the errors more frequently since we updated Skuid to this version.

Does anyone have any ideas on how we can make these page load errors go away for these users?

Comments

  • Hi Joan, sorry to hear your users are getting these errors.

    • Are the errors you're describing the Lightning Component Errors that are generated by Salesforce and display in popups?
    • For affected users with access to the Lightning App Builder, do they still see these errors when they open the page in the Lightning App Builder?
    • Are the affected users using any browser extensions? Do they still get the errors in incognito?
  • These are screenshots for the errors. The same 3 display for a different skuid page we have on the same layout. The answer to your first question seems to be yes. None of the users have access to the Lightning App Builder.

    The users seeing these errors mostly use Firefox. I use Chrome and don't see them. I will reach out to them to see if the affected users have any plugins in their browsers.

  • Heard back from a Firefox user and he has no plugins but sees the errors.

    Their department has someone who exclusively uses Chrome and he sees the errors.


    They have not tried incognito so will try that next.

  • Germany3
    Germany3 🛠️ 

    Hey @Joan Jackson !


    Any updates on whether it worked in incognito?

  • I reached out to my point of contact on this issue and they do NOT get the errors when using incognito mode. However, this is not a viable solution for us. For example, we have various email alerts going out to people when different things happen in Salesforce that they need to know about. When using incognito mode, the links to Salesforce records in these email alerts don't work, so the emails are basically useless. It is very frustrating to not have a better answer for this issue.😑

  • Germany3
    Germany3 🛠️ 

    I understand @Joan Jackson and I'm going to help resolve this issue for you. To make sure I have the most up-to-date info, are you still on  Spark Update 3, version 12.4.13 ?


    Thanks,

  • Yes. Still on that version.

  • Germany3
    Germany3 🛠️ 

    Hey @Joan Jackson,


    Is there a particular group of people that are seeing this? i.e: are they system admins?

    It could be an issue with permissions on the work_order_c object in the screenshots you provided.

    We are looking into why salesforce is kicking back these errors.


    Thanks,

  • The people experiencing this error all have skuid licenses (we hide skuid components from people who don't have licenses) and they all have at least read access and sharing to the objects referenced in the tables. They have View All on all of these objects.

  • Germany3
    Germany3 🛠️ 

    Got it, but the are the actual users using this are coded as: system admins or normal users w/ basic permissions?

  • They belong to a custom profile called Installation Division Manager. They do not have Sys Admin rights. As a Sys Admin I never see these errors.

  • BTW, some of the fields in the skuid table data models reference fields that "belong" to installed packages. Our company uses CPQ, and some of the data they want to see in the skuid tables reference fields that use the CPQ naming convention like SBQQ__xyz__c.

  • Germany3
    Germany3 🛠️ 
    edited April 12, 2021

    Ahh i see, @Joan Jackson if you are the only one not seeing it and you have a higher permission then the others, then it is very possible that you are experiencing a salesforce permissions issue which will explain why your users are experiencing this.


    In addition, can you verify Skuid object permissions and Page object permissions on the Installation Division Manager profile?

  • The Installation Division Manager profile has access to:

    Custom App skuid__Skuid__Lightning but not skuid__Skuid.

    The profile has read create edit delete on the Pages object.

    I don't see an object called Skuid under Custom Objects in the profile.

    I don't see any of the Installation Division Managers in the permission set called Skuid Page Access. Do they need to be in there?

    I do see them in the permission set called Skuid Page Viewer.

    I don't see them (or anyone else) in the permission set called Connect to this Salesforce org's data using Skuid

  • Never mind about the Skuid Page Access permission. That is an old permission set I created that gave certain people access to skuid pages that were visualforce pages embedded in page layouts. Today we don't embed skuid pages in layouts anymore. They are all on lightning record pages wrapped in the skuid lightning component.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!