Skuid page not loading

A skuid page that walks a user through a two step process of collecting data is not loading at times. When the user clears the cache on Chrome it loads again. I cannot find the cache options on the page settings. We are running Skuid 12.4.11.

Comments

  • Screenshot attached
  • Hi Eva, the cache settings you're looking for are not available in V2, but they're also probably not related to the problem you're seeing. When the page fails to load, can you check in the browser's dev console to see if there are any error messages? Those would hopefully provide a hint about what's causing the problem. In short, there are a number of possible causes, so if we can find out more about the circumstances that lead to the problem, that'll help.

  • Hi Mark, I was able to reproduce the error... see attachment as well.

    Error
    at U (https://tolleson--uat--skuid.visualforce.com/resource/1594228737000/skuid__SharedRuntimeJS:2:67202)
    at new r (https://tolleson--uat--skuid.visualforce.com/resource/1594228737000/skuid__SharedRuntimeJS:2:68721)
    at Ce.rejectionMapper (https://tolleson--uat--skuid.visualforce.com/resource/1594228737000/skuid__SharedRuntimeJS:2:119398)
    at De (https://tolleson--uat--skuid.visualforce.com/resource/1594228737000/skuid__SharedRuntimeJS:2:72860)
    at IDBRequest.<anonymous> (https://tolleson--uat--skuid.visualforce.com/resource/1594228737000/skuid__SharedRuntimeJS:2:116168)
    at IDBRequest.<anonymous> (https://tolleson--uat--skuid.visualforce.com/resource/1594228737000/skuid__SharedRuntimeJS:2:74428)
  • ther
    ther
    edited August 19, 2020
    Yes, clearing cache helps but it's not permanent. I used to do this whenever I face any browser error such as [url=https://winerrorfixer.com/err_connection_closed/]Err_Connection_Closed[/url].
  • Here is the error message:
    A cookie associated with a cross-site resource at https://salesforce.com/ was set without the `SameSite` attribute. It has been blocked, as Chrome now only delivers cookies with cross-site requests if they are set with `SameSite=None` and `Secure`. You can review cookies in developer tools under Application>Storage>Cookies and see more details at https://www.chromestatus.com/feature/5088147346030592 and https://www.chromestatus.com/feature/5633521622188032.
  • Thank you for sharing the error details. Eva, can you please check to see if this problem happens in Firefox or Safari? Or is it only happening in Chrome?

  • It is happening in Chrome and not Edge as far as we can tell.
  • Eva Garcia
    Eva Garcia ✭✭
    edited August 21, 2020

    Hello @Mark DeSimone - is there something we could do about the samesite error message?


    Thank you,

    Eva

  • Hi Eva,

    Apologies for the long silence here. If you are still running into this, I believe you may be encountering an issue that came up due to a recent change in Chrome. I would recommend testing the latest Spark update, 12.4.15 in a sandbox where you can reproduce the issue. In 12.4.15 Skuid introduced changes to account for the Chrome changes. You can also look into upgrading to Boston, 13.0.7, which includes these changes plus a bit more aimed at addressing the issue.

    You can read more about this on our releases page, in the notes for issue CORE-3137, "White screen of death" in the notes for Spark update 12.4.14.

    Best practices for upgrading can be found in Upgrading Skuid on Salesforce.  As a reminder, Salesforce does NOT allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. We also recommend that you update out of date themes after you upgrade. Please let us know if you continue to encounter any problems with this issue after upgrading.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!