Salesforce ending support for API Versions. Will it affect Skuid V1 pages?

edited June 17, 2020 in Questions

Will this change affect Skuid V1 pages, and, if so, is there a plan to have a V1 to V2 converter?


What is changing?

With the Summer ‘21 release, the following Lightning Platform API legacy versions will be retired and will no longer be supported by Salesforce:

  • SOAP: 7.0, 8.0, 9.0, 10.0, 11.0, 12.0, 13.0, 14.0, 15.0, 16.0, 17.0, 18.0, 19.0, 20.0

  • REST: v20.0

  • Bulk: 16.0, 17.0, 18.0, 19.0, 20.0

*Currently targeted for June 2021; date subject to change.
Customers can continue to use these legacy API versions until Summer ‘21 is released, when these legacy versions will become unavailable. When these legacy versions are retired, applications consuming impacted versions of the APIs will experience a disruption as the requests will fail and result in an error indicating that the requested endpoint has been deactivated. 

Comments

  • edited June 17, 2020
    Raymond, Salesforce's retiring of these API versions should not affect Skuid users at all. No recent versions of Skuid make use of these SOAP / REST API versions, and Skuid does not currently use the Bulk API.

    Regarding the Skuid Page API Version converter (a different "API Version" than Salesforce's API Versions), yes there is a plan to have a V1 to V2 converter, but the release when this will be available has not been decided yet.
  • edited June 16, 2020
    Great! Thanks!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!