Where is the Field Property 'show column by default' functionality in V2?

PaulPaul ✭✭
edited May 20, 2020 in Questions
When in V2, in a Table, in a Field, there is no 'show column by default' checkbox. I've searched around but can't find it, even though we can give user the Table Configuration feature. Anyone know where I can find it?

Comments

  • Mark DeSimoneMark DeSimone 🛠️ 
    edited March 20, 2020
    Hi Paul,

    Try enabling the table's setting to "Allow column hiding," found under Display >> Configuration area. Once the table's set up with this enabled, each column should have a property labeled "Allow user to hide/show?"

    Can you let me know if this answers your question?


  • PaulPaul ✭✭
    edited March 24, 2020
    @Mark We have that selected but there is no 'Allow user to hide/show' in the Field Properties. We also updated this to the latest V2 version on Friday, hoping that that would resolve the issue, but it did not. Any other ideas?
  • Mark DeSimoneMark DeSimone 🛠️ 
    edited March 24, 2020
    Hmm, if you're not seeing that setting, there are two possible reasons I can think of. First, the setting would only show up if the "Allow Column Hiding" setting was enabled on the table. Second, the field's setting is found by clicking the field in the table, not in the model. You may be looking in the model settings on the field - if that's the case, try following these screenshots and let me know what you see:

    In the table settings, check this box first.

    image

    Then click on the field in the table, and see if you can find the setting here:
    image

    If this isn't what you see, could you send over similar screenshots of what you're seeing?


  • PaulPaul ✭✭
    edited May 20, 2020
    Thanks, Mark. I'm definitely in the field on the table. See my screen shots below.





  • PaulPaul ✭✭
    edited March 26, 2020
    @Mark just following up. Any thoughts on this? Just a reminder, we are using V2. We know this works in V1.
  • PaulPaul ✭✭
    edited May 13, 2020
    @Mark do you have any input here??
  • Mark DeSimoneMark DeSimone 🛠️ 
    edited May 20, 2020
    Hi Paul. Sorry for the delay and confusion. It looks like the ability to hide columns by default in V2 tables is available as of Skuid Spark Update 3. That release was in early access when I tested things out and shared my early responses, so that may have been why you didn't see the same settings. 
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!