Tab Name of a Tabset duplicating in a Wizard

edited October 22, 2019 in Questions
Hey everyone,

We're using a Tabset inside a Wizard. The issue is as follows:

Let's say we have 3 steps in the wizard. Step 2 contains a Tabset with the Tabs "TAB1" and "TAB2".

As you know you can go back to revisit a wizard step. Every time we revisit the second wizard step the tab label is concatenated. So it works like this:

First visit, the tab names are:
TAB1 and TAB2

Second visit:
TAB1TAB1 and TAB2TAB2

Third visit:
TAB1TAB1TAB1 and TAB2TAB2TAB2

and so on..


here's a simple test page:


<skuid__page unsavedchangeswarning="yes" personalizationmode="server" showsidebar="true" showheader="true">
<models/>
<components>
<skuid__wizard uniqueid="sk-3MC_-1192">
<steps>
<step stepId="step1" stepLabel="Step 1">
<components>
<skuid__tabSet uniqueid="sk-3MD0-1649">
<tabs>
<skuid__tabPanel name="TabName">
<components/>
</skuid__tabPanel>
</tabs>
</skuid__tabSet>
</components>
<buttons>
<button label="Next" styleSettingsVariant="primary">
<actions>
<action type="runComponentAction" componentid="sk-3MC_-1192" action="navigateToStep" stepId="step2"/>
</actions>
</button>
</buttons>
</step>
<step stepId="step2" stepLabel="Step 2">
<components/>
<buttons>
<button label="Back">
<actions>
<action type="runComponentAction" componentid="sk-3MC_-1192" action="navigateToStep" stepId="step1"/>
</actions>
</button>
<button label="Next" styleSettingsVariant="primary">
<actions>
<action type="runComponentAction" componentid="sk-3MC_-1192" action="navigateToStep" stepId=""/>
</actions>
</button>
</buttons>
</step>
</steps>
</skuid__wizard>
</components>
<resources>
<labels/>
<javascript/>
<css/>
<actionsequences/>
</resources>
<styles>
<styleitem type="background" bgtype="none"/>
</styles>
</skuid__page>

Any ideas for a JS script or something to fix this?

Thanks

Tagged:

Comments

  • Luzie BaumgartLuzie Baumgart 🛠️ 
    edited October 21, 2019
    Hi Jean-Pierre, thank you for the XML. I couldn't reproduce the issue in Skuid version 12.2.8, please let me know which Skuid version you use and if the issue is still reproducible if you test it in the latest version in a SANDBOX

    I modified your XML slightly to fit the description and used this for testing:

    <skuid__page unsavedchangeswarning="yes" personalizationmode="server" showsidebar="true" showheader="true">
    <models/>
    <components>
    <skuid__wizard uniqueid="sk-3MC_-1192">
    <steps>
    <step stepId="step1" stepLabel="Step 1">
    <components>
    </components>
    <buttons>
    <button label="Next" styleSettingsVariant="primary">
    <actions>
    <action type="runComponentAction" componentid="sk-3MC_-1192" action="navigateToStep" stepId="step2"/>
    </actions>
    </button>
    </buttons>
    </step>
    <step stepId="step2" stepLabel="Step 2">
    <components>
    <skuid__tabSet uniqueid="sk-3MD0-1649">
    <tabs>
    <skuid__tabPanel name="TAB1">
    <components/>
    </skuid__tabPanel>
    <skuid__tabPanel name="TAB2">
    <components/>
    </skuid__tabPanel>
    </tabs>
    </skuid__tabSet>
    </components>
    <buttons>
    <button label="Back">
    <actions>
    <action type="runComponentAction" componentid="sk-3MC_-1192" action="navigateToStep" stepId="step1"/>
    </actions>
    </button>
    <button label="Next" styleSettingsVariant="primary">
    <actions>
    <action type="runComponentAction" componentid="sk-3MC_-1192" action="navigateToStep" stepId="step3"/>
    </actions>
    </button>
    </buttons>
    </step>
    <step stepId="step3" stepLabel="Step 3">
    <components/>
    <buttons>
    <button label="Back">
    <actions>
    <action type="runComponentAction" componentid="sk-3MC_-1192" action="navigateToStep" stepId="step2"/>
    </actions>
    </button>
    </buttons>
    </step>
    </steps>
    </skuid__wizard>
    </components>
    <resources>
    <labels/>
    <javascript/>
    <css/>
    <actionsequences/>
    </resources>
    <styles>
    <styleitem type="background" bgtype="none"/>
    </styles>
    </skuid__page>
  • edited October 21, 2019
    Hi Luzie,

    Thank you for your answer and the adjusted XML. We're on Skuid Platform on version 12.2.6.1
    Is there a way to upgrade to 12.2.8? As far as we can see Platform is not on 12.2.8 yet: https://www.skuid.com/releases/

    Thanks,
    JP
  • Luzie BaumgartLuzie Baumgart 🛠️ 
    edited October 22, 2019
    Hi Jean-Pierre, thanks that makes sense. I could have known that you are on Platform because you posted this under "Skuid Platform", I'm sorry I missed that. I could reproduce the issue on Platform and will report it to our development team. Please ignore my information of Skuid version 12.2.8, that's only relevant if you use Skuid on Salesforce. Thanks again for informing us about the issue!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!