Lightning Component Error

Conlan O'RourkeConlan O'Rourke ✭✭✭✭
edited April 8, 2019 in Questions
Hi Skuid Support team,

I previously posted this error message on another thread, but moving this to it's own thread to help gain visibility here in the community, and hopefully get a response soon. We're intermittently experiencing the error message screenshot attached below.

To give you context, we've developed a CPQ solution that runs the Skuid page in a lightning component on the the Opportunity page. The solution works well on its own, and we don't experience the issue when the user lands on the Lightning Opportunity Page after using SF's Global Search Bar. However, if the user clicks into the Opportunity from another related record (e.g. Account or Quote), the error consistently appears.

I also get this error message when moving the location of the Skuid Page as a Lightning Component within the Lightning App Builder.

What I've done: 
  1. Solution is built in sandbox and ready to deploy to production. This was caught during UAT. 
  2. I made sure to generate Page Support Files for my in-line javascript. Issue persists.
  3. I'm not re-directing to this page at all, the user just lands on it as a Lightning Component within the Opportunity Lightning Page. So no absolute URLs being used.
  4. My Domain is enabled.
This is going to prevent us from deploying this solution, and I don't currently have any workarounds. If you could have the engineers look into this one, it would be greatly appreciated.

I am happy to provide login access or whatever is needed to troubleshoot.

Thank you in advance!



Comments

  • Conlan O'RourkeConlan O'Rourke ✭✭✭✭
    edited March 15, 2019
    I'm not going to say this issue is fully resolved just yet...but after browsing this thread, I had the suspicion this was due to some kind issue with Skuid error handling and asynchronous loading of the Skuid page in Lightning...here's what I did, and it appears the issue has been resolved...although I'll be testing heavily over the next few days.

    1) I moved my Skuid Page Lightning component out of the default tab on my Opportunity page...so after the page loads, the user has to click into the tab where the Skuid page sits in order to see the Skuid page.

    2)  Made sure none of my models query on page load. 

    3) Noticed I had a model with "Allow Page Render Before Query Completes" checked...so I unchecked this.

    I'll confirm later if this truly resolves the issue.
  • Conlan O'RourkeConlan O'Rourke ✭✭✭✭
    edited March 23, 2019
    Unfortunately...we're continuing to experience this issue 
  • Conlan O'RourkeConlan O'Rourke ✭✭✭✭
    edited March 23, 2019
    Just another follow-up here...it's appearing that this only arises when the Skuid page is immediately displayed/rendered upon a Lightning page load. Whenever we locate the Skuid page "behind" a Lightning Tab, which the user must click after the Lightning Detail page has already loaded...this issue resolves again.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!