Can't Edit Fields or Sort Columns - MariaDB Data

jdbuergerjdbuerger Member ✭✭
edited March 2019 in Questions
I'm trying to use Squid Platform along with a MariaDB database. I can bring the data into a table OK and see it, but there is no way to sort columns like in the original API. When I click on the edit icon on a cell in the table, it highlights the cell below the one where the icon is ... and still won't let me edit anything. I tried changing the table to edit all mode and this allows me to highlight a cell, but I still can't change anything. Chrome browser. Same issue applies in V1 API. I cannot edit anything.


  • Huyen YorkHuyen York Skuad
    edited March 2019
    Hi jdbuerger,

    I haven't used Skuid + MariaDB myself but here's my experience with PostgreSQL that might be helpful.

    Regarding the columns not being sortable, that might not be enabled in your field settings in Datasource Object configuration. In the Datasource Object configuration screen, you can click the gear icon for the table to drill down to the fields, then click the gear icon for the field to see the field settings. Make sure Sortable is checked for the field

    In order to edit data, you have to have a Primary Key in your table in your DB, and in Skuid, that field must be checked as the Id field (it will be checked automatically when imported if it's set in the DB as Primary Key)


  • jdbuergerjdbuerger Member ✭✭
    edited March 2019
    Thanks Huyen. That fixed the edit problem. Still can't get sorting to work. Condition Filters seem to work correctly as long as the field is indexed at the DB file (throws an error after a while if not) but sorting functionality is non-existent in either v2 or v1. I have to assume it's something to do with the MariaDB and how it is set up, but I can't figure out what's missing.
  • Huyen YorkHuyen York Skuad
    edited March 2019
    So I found a MySQL/MariaDB db to test and it seems like on a V2 page (using new Ink components), sorting columns work both server-side and client-side. If you are sure that you have the fields set to be sortable in the field setting in Data Source Objects setting (here's how, then it might be something to do with the MariaDB, but I can't imagine what it might be since I'm testing with a very simple table 
Sign In or Register to comment.