html escaping issue with picklist values that contain apostrophe

edited September 2019 in Problems
I've tried on a few different themes, and I've upgraded to 11.2.10 but the issue persists.


As displayed on Skuid page...

image

Salesforce picklist values...
image

Comments

  • edited September 2019
    Is that column a template field, displaying {{Service_Location__c}}? If so, try {{{Service_Location__c}}}.

    [It's nice to see data I can relate to, from what looks like the justice system!]

  • edited October 2018
    Hi Mike, 

    No not a template field, just a regular old field. I tried your suggestion using the template field with 3 curly brackets, but the issue is persisting even in the template field.

    [Yes, building out Case Management, Residential Services, and Legal Services applications for an human services agency]
  • edited September 2019
    I'm thinking theme or css then, which are not my expertise. I can't duplicate the display with any of the culprits I can come up with.
  • edited November 2018
    Bump
  • edited November 2018
    Just a thought - what happens if you edit the picklist value in Salesforce and insert the inverted comma using your keyboard - i.e. manually type in the picklist value - could be an artefact from a copy/paste into the picklist value?
  • edited November 2018
    Louis - thanks, this in fact was a result of a copy/paste artefact as you said. However, I was a bit of an idiot here because I had previously solved this issue, but only de-activated the bad value instead of deleting and replacing with the valid value. So those records were still just referencing the de-activated (bad) value.

    My bad... :/
Sign In or Register to comment.