After upgrade to Mileau, Chatter broken with error "page social does not exist"

edited August 27, 2018 in Questions
We've just upgraded to v11 from v8 and now our Chatter widgets are showing a full Salesforce page with the error "Page Social does not exist".

As it's a full SF page, it's breaking our layout until we remove the widget.

After reading other related posts here, I've tried removing the widget, saving, and add it again, but not luck - I get the same error.

What do I need to do to get the Chatter widget working again?

Thanks.

Comments

  • J.J. 💎
    edited August 27, 2018
    Hi, Evan. Check out this note from our Millau Release Notes. In order to get our Chatter Component to work with client loaded models, we had to make some changes that required you to clone our Social Visual Page to your local namespace. Give that a shot and it should start working again for you.
  • Zach McElrathZach McElrath Principal Software Engineer Chattanooga, TN 💎💎💎
    edited August 27, 2018
    Evan, which Skuid release did you upgrade to, exactly? Are you on 11.1.x, or 11.2.x , and if so, which release number? This error rings a bell, i believe there was something we fixed in a patch release.

    Are you using the Redirect or skuid:page component Visualforce override method? You may need to make a local clone of the Social page in order to get this to work, as described here:

    https://docs.skuid.com/latest/en/skuid/deploy/salesforce/visualforce/skuid-page-visualforce-componen...


  • edited August 27, 2018
    That did indeed solve the problem. Thanks!
  • edited August 27, 2018
    One note for others that might find this. I did need to add permissions to the new Visualforce page to get it to show up for users other than admins.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!