Security notice on email fields

AllisonAllison ✭✭✭
edited June 19, 2018 in Questions
We have just started getting this security notice when clicking on email fields (to open computer's email editor).  We don't get the error in a native SF page, on page load or on other types of pop-ups (like urls to outside pages)

image

Comments

  • Matthew LeahyMatthew Leahy ✭✭✭
    edited June 18, 2018
    Hi Allison,

    This is a warning being issued by your browser. Once you "Allow", do you get this prompt on subsequent tries?

    I found a forum post that may explain the issue better. 

    Most likely you have "mixed content". Visitors to sites protected by SSL expect (and deserve) security and protection. When a site doesn’t fully protect or secure all content, a browser will display a “mixed-content” warning. Mixed content occurs when a webpage containing a combination of both secure (HTTPS) and non-secure (HTTP) content is delivered over SSL to the browser. Non-secure mixed-content-error content can theoretically be read or modified by attackers, even though the parent page is served over HTTPS.

    To fix this you would need to be able to identify the non secure content within the code of the site. Most common day browsers like Google Chrome and Mozilla Firefox have an ability to look at the code in a developer instance meaning its like debugger console built into the browser. In Google Chrome you would right click on the page that is displaying the warning and select "Inspect." On Mozilla Firefox same idea but they call it "Inspect Element." Once you have done this look for any "Mixed Content" warnings.

    Let us know if this was helpful. 
  • AllisonAllison ✭✭✭
    edited June 18, 2018
    Thanks for the super-quick reply.  I didn't think it was related to the entire page because we don't get the error on page load, only when clicking on the email field (opening new email window).  

    If I change the email field's metadata type from email to url in the skuid model, I also don't get the error (but then, can't get the email window to open properly).

    There isn't an option to "allow" since all the settings are already set to allow, the certificate is valid through 2019, etc.


  • Matthew LeahyMatthew Leahy ✭✭✭
    edited June 18, 2018
    Sorry, I thought the browser was giving you the option to change Notifications and Popups settings and defaulted to "Allow".

    Do you get an error message(s) in the developer console when you click the email address?

  • AllisonAllison ✭✭✭
    edited June 18, 2018
    no, no entries in the developer console at all when clicking on the email.
  • Matthew LeahyMatthew Leahy ✭✭✭
    edited June 18, 2018
    I'll keep checking on my end. Go ahead and share the browser you're using and version of Skuid.

    Let's see if anyone on the community has experienced this issue. 
  • AllisonAllison ✭✭✭
    edited June 18, 2018
    Thanks.  We're on Chrome and just upgraded to the lastest Skuid update 11.2
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!