Pie Chart Text Colors Out of whack

Pat VachonPat Vachon 💎💎💎
edited October 26, 2018 in Questions
Skuid 11.1.13
Themes Updated
Any theme.

image

Comments

  • edited June 8, 2018
    I haven't been able to replicate this. Do you see it here in the XML below? What am I missing?

    <skuidpage unsavedchangeswarning="yes" personalizationmode="server" showsidebar="false" useviewportmeta="true" showheader="false" theme="Modern">
        <models>
            <model id="Account" limit="20" query="true" createrowifnonefound="false" datasource="salesforce" sobject="Account">
                <fields>
                    <field id="RecordTypeId"/>
                    <field id="Name"/>
                    <field id="Type"/>
                </fields>
                <conditions/>
                <actions/>
            </model>
        </models>
        <components>
            <skuidvis__chart model="Account" maintitle="{{Model.labelPlural}}" type="pie" uniqueid="sk-3Wje-423">
                <dataaxes>
                    <axis id="axis1"/>
                </dataaxes>
                <categoryaxes>
                    <axis id="categories" categorytype="field"/>
                </categoryaxes>
                <serieslist>
                    <series valuefield="Type" splittype="field" modelId="Account" aggfunction="count" type="pie" splitfield="Type"/>
                </serieslist>
                <colors/>
                <legend layout="horizontal" halign="center" valign="bottom"/>
            </skuidvis__chart>
            <skootable showconditions="true" showsavecancel="true" showerrorsinline="true" searchmethod="server" searchbox="true" showexportbuttons="false" hideheader="false" hidefooter="false" pagesize="10" alwaysresetpagination="false" createrecords="true" model="Account" buttonposition="" mode="read" allowcolumnreordering="true" responsive="true" uniqueid="sk-3Wj3-269">
                <fields>
                    <field id="Name" hideable="true" uniqueid="fi-3Wj5-292"/>
                    <field id="Type" hideable="true" uniqueid="fi-3Wj5-293"/>
                </fields>
                <rowactions>
                    <action type="edit"/>
                    <action type="delete"/>
                </rowactions>
                <massactions usefirstitemasdefault="true">
                    <action type="massupdate"/>
                    <action type="massdelete"/>
                </massactions>
                <views>
                    <view type="standard"/>
                </views>
            </skootable>
        </components>
        <resources>
            <labels/>
            <javascript/>
            <css/>
            <actionsequences uniqueid="sk-3Wi5-230"/>
        </resources>
        <styles>
            <styleitem type="background" bgtype="none"/>
        </styles>
    </skuidpage>

  • edited October 26, 2018
    I hit this bug, and figured out how to fix it (I'm on 11.2.5, so it's still pretty recent). 

    I cloned a number of components at once, and converted the chart from a stacked bar to a pie chart. This cause this to be included in the XML:

    stacking="true"

    Removing that in the XML manually fixes it.


Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!