Sliding Panel not working from a Deck Interaction

Josef Lagorio
edited January 18, 2018 in Questions
I am trying to recreate the Mobile Page Builder "panel" user experience by using a sliding panel from within a deck component, however the sliding panel isn't sliding. It is doing absolutely nothing when I "Click".

Comments

  • Stephen Sells
    edited December 5, 2017
    Could you share your setup?
  • Josef Lagorio
    edited December 5, 2017
    I've created a bare bones example page, but even that does not work. 

    <skuidpage unsavedchangeswarning="yes" personalizationmode="server" showsidebar="true" useviewportmeta="true" showheader="true">
        <models>
            <model id="Account" limit="20" query="true" createrowifnonefound="false" datasource="salesforce" type="" sobject="Account">
                <fields>
                    <field id="Name"/>
                </fields>
                <conditions/>
                <actions/>
            </model>
        </models>
        <components>
            <deck searchmethod="server" searchbox="true" columngutter=".75em" rowgutter=".75em" filtersposition="top" filterswidth="150px" showsavecancel="false" behavior="flex" verticalalign="top" ratio="1" minwidth="350px" uniqueid="sk-dczlC-111" buttonposition="" pagesize="10" model="Account">
                <components>
                    <basicfieldeditor showheader="true" showsavecancel="true" showerrorsinline="true" buttonposition="" uniqueid="sk-dd280-137" mode="read" model="Account">
                        <columns>
                            <column width="100%">
                                <sections>
                                    <section title="Section A" collapsible="no">
                                        <fields>
                                            <field uniqueid="sk-ddAqR-180" id="Name"/>
                                        </fields>
                                    </section>
                                </sections>
                            </column>
                        </columns>
                    </basicfieldeditor>
                </components>
                <massactions/>
                <interactions>
                    <interaction type="tap" direction="either">
                        <action type="openSlidingPanel">
                            <models/>
                            <popup title="{{Model.label}}: {{Name}}" width="80%">
                                <components/>
                            </popup>
                            <panel title="Sliding Panel Contents" uniqueid="sk-dc-Z--129" size="100%" origin="left" closeonpageclick="true" behavior="overlay">
                                <components>
                                    <richtext multiple="false" uniqueid="sk-ddCpy-189" model="Account">
                                        <contents>&lt;p style="user-select: auto;"&gt;{{Name}}: THIS DOES NOT WORK&lt;/p&gt;
    </contents>
                                    </richtext>
                                </components>
                            </panel>
                        </action>
                    </interaction>
                </interactions>
                <actions/>
                <styles>
                    <styleitem type="border"/>
                </styles>
            </deck>
        </components>
        <resources>
            <labels/>
            <javascript/>
            <css/>
        </resources>
        <styles>
            <styleitem type="background" bgtype="none"/>
        </styles>
    </skuidpage>
  • Josef Lagorio
    edited December 5, 2017
    I am trying to build mobile experience similar to the old mobile page composer that allowed for panel layering 
  • Stephen Sells
    edited December 5, 2017
    Thank you for bringing this to our attention. It appears there's an issue in how Interactions work in Decks. I am logging this as a known issue in our tracking system so I will archive this ticket here.  There is not a target date for getting this issue addressed yet but our devs are aware of it.
  • Stephen Sells
    edited January 18, 2018
    Thank you for your patience! Skuid has fixed the issue you raised in the new 11.0.4 and 10.0.14 release which is now available on the Skuid Releases page.

    As a reminder, Salesforce does NOT allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. We also recommend that you update out of date themes when you upgrade. Please let us know if you continue to encounter any problems with this issue after upgrading.
     
    Thanks again for alerting us of these issues!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!