Console error related to proxy request

Bill McCulloughBill McCullough 💎💎
edited October 31, 2017 in Questions
Skuid Team,

We updated our full sandbox to 10.0.0.10 from 8.15.17.  We are testing our pages and we found that we are consistently seeing an error in the console related to a Get request.  It is showing a 401 Unauthorized request error.  In the console we see a proxy request with the following URL: https://mydomain.visual.force.com/services/proxy?_=1509106726549

This is happening in production (still on 8.15.17).  In production this error is only adding ~100 ms of delay in page loading.  In the full sandbox, this error can add 3000 - 4000 ms of delay in page loading.  It seems worse with list views where we return multiple records.

The screenshots are from our Sandbox.  I created a simple contact detail page using the 'template' feature of the new page wizard.  The contact model on this page only loads 1 record and 1 field.
 
Any ideas on how we can fix this?

Thanks,

Bill
image
image

Comments

  • Zach McElrathZach McElrath Principal Software Engineer Chattanooga, TN 💎💎💎
    edited October 27, 2017
    Bill, the error you are reporting is not coming from Skuid code --- Skuid does not use 'forcetk' and does not make requests to /services/proxy. Is there some logic you have running in a Sidebar component that uses ForceTK ?

    Either way, I am pretty sure this is not coming from Skuid.
  • Bill McCulloughBill McCullough 💎💎
    edited October 27, 2017
    Zach,

    Thanks for your input on this.  While we do not have a custom Sidebar component, your clue led me to look at what browser extensions I have running (on Chrome).

    The error came from an extension to delete debug logs from Salesforce.  Disabling the extension removed the console error.

    Best,

    Bill
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!