Tab navigation picklist rendering problem

edited March 26, 2020 in Questions
Second tab in "tab set" doesn't show up.

When we use tab navigation "picklist" in "tab set"  and add render condition to any tab (we are using 6 tabs), 
we are missing second tab even if this tab doesn't have render condition.

Component Structure:

Tab Set - Navigation Set = picklist
-----Tab A - Render Condition no met
----------Table
-----Tab B - No Render Condition (This tab is missing)
----------Table
-----Tab C - No Render Condition
----------Table

This issue seems to just apply when we are using picklist as tab navigation.

I've build a repro page off the contact object so you can help me to validate this issue.

Full page repro:

<skuidpage unsavedchangeswarning="yes" personalizationmode="server" useviewportmeta="true" showsidebar="true" showheader="true" tabtooverride="Contact">
    <models>
        <model id="Contact" limit="100" query="true" createrowifnonefound="false" datasourcetype="salesforce" datasource="salesforce" sobject="Contact">
            <fields>
                <field id="FirstName"/>
                <field id="LastName"/>
                <field id="CreatedDate"/>
                <field id="Email"/>
                <field id="Title"/>
            </fields>
            <conditions/>
            <actions/>
        </model>
    </models>
    <components>
        <pagetitle model="Contact" uniqueid="sk-1GdG-y-86">
            <maintitle>
                <template>{{Model.labelPlural}}</template>
            </maintitle>
            <subtitle>
                <template>Home</template>
            </subtitle>
            <actions>
                <action type="savecancel" uniqueid="sk-1GdG-x-85"/>
            </actions>
        </pagetitle>
        <tabset rememberlastusertab="true" defertabrendering="true" uniqueid="sk-1GdNiJ-124" renderas="picklist">
            <tabs>
                <tab name="Tab A">
                    <components>
                        <skootable showconditions="true" showsavecancel="false" searchmethod="server" searchbox="true" showexportbuttons="false" pagesize="10" createrecords="false" model="Contact" mode="readonly" allowcolumnreordering="true" uniqueid="sk-1GdH0P-97">
                            <fields>
                                <field id="FirstName" hideable="true" allowordering="true" uniqueid="fi-1GdG0t-415"/>
                                <field id="LastName" hideable="true" allowordering="true" uniqueid="fi-1GdG0t-416"/>
                                <field id="CreatedDate" hideable="true" allowordering="true" uniqueid="fi-1GdG0t-417"/>
                            </fields>
                            <rowactions/>
                            <massactions usefirstitemasdefault="true"/>
                            <views>
                                <view type="standard"/>
                            </views>
                        </skootable>
                    </components>
                    <renderconditions logictype="and">
                        <rendercondition type="fieldvalue" operator="=" enclosevalueinquotes="true" fieldmodel="Contact" sourcetype="fieldvalue" nosourcerowbehavior="deactivate" field="FirstName" fieldtargetobjects="Contact" value="Victor"/>
                    </renderconditions>
                </tab>
                <tab name="Tab B" loadlazypanels="true">
                    <components>
                        <skootable showconditions="true" showsavecancel="false" showerrorsinline="true" searchmethod="server" searchbox="true" showexportbuttons="false" pagesize="10" alwaysresetpagination="false" createrecords="false" model="Contact" buttonposition="" mode="readonly" allowcolumnreordering="true" responsive="true" uniqueid="sk-1GdiEs-213">
                            <fields>
                                <field id="FirstName" hideable="true" uniqueid="fi-1GdkZs-230"/>
                                <field id="LastName" hideable="true" uniqueid="fi-1GdkZu-231"/>
                                <field id="Email" hideable="true" uniqueid="fi-1Gdz6g-323"/>
                            </fields>
                            <rowactions/>
                            <massactions usefirstitemasdefault="true"/>
                            <views>
                                <view type="standard"/>
                            </views>
                        </skootable>
                    </components>
                </tab>
                <tab name="Tab C" loadlazypanels="true">
                    <components>
                        <skootable showconditions="true" showsavecancel="false" showerrorsinline="true" searchmethod="server" searchbox="true" showexportbuttons="false" pagesize="10" alwaysresetpagination="false" createrecords="false" model="Contact" buttonposition="" mode="readonly" allowcolumnreordering="true" responsive="true" uniqueid="sk-1GdlrM-244">
                            <fields>
                                <field id="FirstName" hideable="true" uniqueid="fi-1Gdnov-261"/>
                                <field id="LastName" hideable="true" uniqueid="fi-1Gdnow-262"/>
                                <field id="Title" hideable="true" uniqueid="fi-1Ge4LI-343"/>
                            </fields>
                            <rowactions/>
                            <massactions usefirstitemasdefault="true"/>
                            <views>
                                <view type="standard"/>
                            </views>
                        </skootable>
                    </components>
                </tab>
            </tabs>
        </tabset>
    </components>
    <resources>
        <labels/>
        <css/>
        <javascript/>
    </resources>
    <styles>
        <styleitem type="background" bgtype="none"/>
    </styles>
</skuidpage>

Comments

  • edited October 25, 2017
    Thank you for bringing this to our attention!

    It appears there's an issue in how we are handling tabs that are set to picklists. I am logging this as a known issue in our tracking system. There is not a target date for getting this issue addressed yet but our devs are aware of it. We'll notify you here when a fix goes out. Thank you for your patience.
  • edited July 22, 2019
    I am seeing this same issue. Has this ever been fixed? Is there a work around that can be used?
  • edited July 23, 2019
    We have this issue as well... Any updates?
  • Clark CreggClark Cregg ✭✭✭
    edited August 15, 2019
    Hello Emma & Daniel,

    I am working on tracking this one down and will report back when I have some information to report. 

    Thanks,
    Clark  

  • edited July 23, 2019
    Emma,
    I unfortunately had to use this workaround for now. Seems the issue is always with the second tab. So I created a second tab named Do Not Use and moved my second tab to the third tab position.  Seems second never shows up during my testing and third tab does. Not ideal for sure but it seems to work.
  • edited August 12, 2019
    Hi Clark,

    Thanks for following up with this, I was just wondering if there has been any progress with the issue?

    Thanks,
    Emma
  • Clark CreggClark Cregg ✭✭✭
    edited August 15, 2019
    Hello Emma! 

    The issue has been reported to the product team. Looks like its slated to be worked on, but no current ETA. I have a reminder set to check in on it. I will let you know if I hear anything, thanks for your patience!

    Thank you,
    Clark
  • Brian LeeBrian Lee 🛠️ 
    edited March 26, 2020
    Thank you for your patience! Skuid has fixed the issue you raised regarding Tab navigation picklist rendering (issue DSC-1151) in the recent 12.1.11 release which is now available on the Skuid Releases page.

    As a reminder, Salesforce does NOT allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. We also recommend that you update out of date themes after you upgrade. Please let us know if you continue to encounter any problems with this issue after upgrading.
     
    Thanks again for alerting us of this issue!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!