Most Icons Don't Work in 10.0.9

Pat VachonPat Vachon Member ✭✭
edited June 25 in Problems
As per subject.

Tried in Tab Set, Button and Row Action. Only Standard and FA3 work. 

image
Tagged:

Comments

  • Pat VachonPat Vachon Member ✭✭
    edited June 25
    Also in version 10.0.6
  • Pat VachonPat Vachon Member ✭✭
    edited June 25
    Works in 10.0.0
  • edited June 25
    My icons just disappeared. I didn’t upgrade skuid. They were working on Friday, now they are not. I think I am on 10.0.5
  • Pat VachonPat Vachon Member ✭✭
    edited October 2017
    Now that is strange.
  • edited October 2019
    They just came back.... strange days are upon us....
  • Amy DewaalAmy Dewaal Member, Skuad ✭✭
    edited June 25
    Pat,

    Are your icons back as well? I am able to see icons from any of the icon sets on 10.0.9, so I'm not sure what's going on with your icons.
  • Pat VachonPat Vachon Member ✭✭
    edited October 2017
    Still missing. Updated themes and hard refreshed the page cache.
  • Mark DeSimoneMark DeSimone Skuid Mod 🛠️ 
    edited October 2017
    Pat, do you see any messages in the browser console or network overview indicating that some resources didn't load?
  • Pat VachonPat Vachon Member ✭✭
    edited October 2017
    Spot on.  Ideas?

    image
  • Mark DeSimoneMark DeSimone Skuid Mod 🛠️ 
    edited October 2017
    It looks like the URL for the frame your page is in has a different subdomain than the icon static resource. Can you describe more about this page's environment - I see it's in a Visualforce page. Does the problem happen also when you're previewing the Skuid page itself? 
  • Pat VachonPat Vachon Member ✭✭
    edited October 2017
    It's not a problem when previewing the page.

  • Mark DeSimoneMark DeSimone Skuid Mod 🛠️ 
    edited October 2017
    Is the affected Skuid page loading in an iframe? If so, are you able to change the subdomain so it matches what's showing in the error message you captured in your screenshot?
  • Pat VachonPat Vachon Member ✭✭
    edited November 2017
    Works in Preview.
    https://skuid.na35.visual.force.com/apex/skuid__ui?page=FirstClinicDayManager

    Fails in VF page deployment
    https://c.na35.visual.force.com/apex/First_Clinic_Manager?sfdc.tabName=01r410000017UkR
    <apex:page readonly="true"   showheader="true"   sidebar="false"   doctype="html-5.0"   title="First Clinic Manager">     <skuid:page page="FirstClinicDayManager"/> </apex:page>
  • Mark DeSimoneMark DeSimone Skuid Mod 🛠️ 
    edited February 4
    Hi Pat, I am able to reproduce this using an icon from the newer sets like the ION icon set. Font Awesome and Standard icon sets look to be unaffected, but the other icon sets don't appear to load when used inside a Skuid-in-Visualforce page. I will submit this as a product issue, and update this conversation when a resolution is released. Thank you for taking the time to contribute to this thread!
  • Mark DeSimoneMark DeSimone Skuid Mod 🛠️ 
    edited February 4
    Hello Pat, when product issue CORE-1225 "Static Resources fail to load for Skuid on Salesforce from URLs other than My Domain URL" was recently resolved in Skuid 11.0.5, the icon set load issue was also fixed. 

    Of course, because Salesforce does not support reverting to old versions of installed packages, Skuid always recommends testing out any new version in a non-mission-critical sandbox to ensure all functionality is intact. 
  • Arne-Per HeurbergArne-Per Heurberg Member ✭✭
    edited March 2018
    Hi Mark, Did it revert in 11.1.6? Icons show in preview but not actual page. Thanks!
  • Mark DeSimoneMark DeSimone Skuid Mod 🛠️ 
    edited March 2018
    Arne-Per,

    I'm seeing errors that are very similar to what we saw prior to the fix. I believe this issue may have recently resurfaced, and I've made our development team aware of this. We will update this Community thread as new information is available. Thank you for letting us know.
  • Stephen SellsStephen Sells Member
    edited June 2018

    Hello Skuid Community ~

    This has been addressed in the new Millau 11.2.2 release which is now available on the Skuid Releases page.

    As a reminder, Salesforce does NOT allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. We also recommend that you update out of date themes when you upgrade.
Sign In or Register to comment.