Updating field with Mass Action gives error Invalid Number Format

Jim WJim W Member
edited October 2019 in Problems
I am trying to update a field using a mass action. I have a UI Only field that calculates a new amount for a field using a COLA (Cost Of Living Adjustment). Both the UI field and the destination field have the same format (Currency 9,0). The field that is trying to be update is referenced in the UI only formula field. Does anyone have any ideas what may be causing this error?  Thank you!imageimageimageimage

Comments

  • edited October 2019
    Try changing the UI only format to number of text. It is probably formatting the number as currency but the input to the salesforce field doesn't want the extra formatting.
  • Jim WJim W Member
    edited July 2017
    I just tried setting it to number and then text, and I'm still getting the same error.
  • edited October 2019
    If you type the number into the field manually, do you get an error?
  • Jim WJim W Member
    edited July 2017
    No, I just typed the number in there and it took it no problem.  I'm just wondering, could it have something to do with the fact that the field I am trying to update is used in the calculation of the UI field...?
  • edited October 2019
    I know what you are saying. Try taking it out. Actually try just entering a number in the UI only formula that "should" work and see if it is the formula that's causing the problem or the UI field itself.
  • Jim WJim W Member
    edited July 2017
    i'm still getting the same error.... I just changed the formula to this... is that what i should do?image
  • edited October 2019
    At this point, I'd probably try to put the Cola calc in a salesforce formula field, bring it into the model and use that to update. Another option would be to make the field you are updating a text field instead of currency which would probably make it more forgiving of input.
  • Jim WJim W Member
    edited July 2017
    I will give that a try - thanks for your assistance!
  • Stephen SellsStephen Sells Member
    edited July 2017
    Were you able to get this functionality to work?
  • Jim WJim W Member
    edited July 2017
    Well, I did the last thing that Raymond suggested, (put calc in SF field) and it worked that way. I have to move on to a new project now, but will probably have to revisit more of this at some point... I don't know why it didn't work the other ways, but at least it worked. Thanks.
Sign In or Register to comment.