Pass Id in page include

BillBill Member ✭✭
edited May 12 in Problems
I have done this man times with success.  I am passing and Id in a page include and it does not pass.  I have included a video showing the issue.
https://drive.google.com/file/d/0B409lhd9sYDcUHBLbkZ2ZnN1akU/view

Comments

  • Joseph OrtizJoseph Ortiz Member
    edited May 2017
    is the model loaded on page load? You check if that setting is configured by looking on the model.
  • BillBill Member ✭✭
    edited May 12
    yes
  • BillBill Member ✭✭
    edited May 12
    I also tried putting in a collapsible wrapper.
    image
    image
    image
    Entity_Id={{{$Model.Select_Entity_Id.data.0.Id}}}
    image
    image
    image
  • Stephen SellsStephen Sells Member
    edited April 2017
    What is different about this page compared to the ones that work? If you have the same setup in other pages working perfectly, that makes me wonder what is different here or what is different on the Page Include. 

    When you compare the two, what do you find that is different?
  • BillBill Member ✭✭
    edited May 12
    Entity_Id={{{$Model.Select_Entity_Id.data.0.Id}}}
    Entity_Id=a0qj0000001YDurAAG
  • BillBill Member ✭✭
    edited May 12
      Here is the XML for the 2 page includes as well the Id that is being passed.
    image
    Here are the conditions on the included page
    image
    Here is how it renders.
       
    image








         <grid uniqueid="sk-25xKd7-3041">            <divisions>
                    <division behavior="flex" minwidth="100px" ratio="1" verticalalign="top">
                        <components>
                            <richtext multiple="false" uniqueid="sk-1nP189-4237" model="Person">
                                <contents>&lt;p&gt;Entity_Id={{{$Model.Select_Entity_Id.data.0.Id}}}&lt;/p&gt;
    </contents>
                            </richtext>
                            <includepanel type="skuid" uniqueid="sk-1iw1KA-3016" pagename="RM1_CR_Marker" module="" querystring="Entity_Id=a0qj0000001YDurAAG">
                                <renderconditions logictype="and"/>
                            </includepanel>
                            <includepanel type="skuid" uniqueid="sk-1naJoG-3037" pagename="RM1_CR_Marker" module="" querystring="Entity_Id={{{$Model.Select_Entity_Id.data.0.Id}}}">
                                <renderconditions logictype="and"/>
                            </includepanel>
                        </components>
                    </division>
                </divisions>
                <styles>
                    <styleitem type="background" bgtype="none"/>
                </styles>
            </grid>
  • BillBill Member ✭✭
    edited May 12
    Could this be causing the problem?

    skuid__JQueryJS:4 Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check https://xhr.spec.whatwg.org/.

  • BillBill Member ✭✭
    edited May 12
    Fixed
  • Stephen SellsStephen Sells Member
    edited April 2017
    Glad to hear it. What was the problem in the end? 
  • Matt SonesMatt Sones Member ✭✭
    edited August 2017
    Bill... looks like i'm having the same issue upon upgrading from Banzai to Brooklyn (9.5.10). I'm passing a reference field and it's getting the name instead of the id. How did you fix it?
Sign In or Register to comment.