Brooklyn Problem - PlatformJS not available as Public Resource for Force.com Sites

edited March 7, 2017 in Questions
I just installed Brooklyn in a sandbox. Everything is working well, but I am getting an error on some Force.com sites I have built with Skuid VF pages. I built these awhile back following this great tutorial - http://help.skuid.com/m/11720/l/114236-build-force-com-sites-with-skuid#!prettyPhoto

Everything worked fine until I installed Brooklyn. Now I get this error on load - ' http://partialcop-abelcine.cs62.force.com/abelcine/resource/1480529442000/skuid__PlatformJS Failed to load resource: the server responded with a status of 404 (Not Found) ' 

PlatformJS is no doubt new, and is not a public resource. Is that perhaps the problem?

Any idea what is going on here?


Comments

  • Karen WaldschmittKaren Waldschmitt 🛠️ 
    edited March 2, 2017
    Andrew~

    Thank you for bringing this to our attention!!! Unfortunately, you have found a bug in Brooklyn. When a fix is available that addresses this bug, we will update you here. 

    Sorry for any inconvenience this may be causing you!!!
    Karen
  • edited December 1, 2016
    I also use Skuid in this sense and am getting the same bug.  A fix would be greatly appreciated as a number of our executives depend on external pages we have created.

    Is there a workaround I can implement in the short term until a fix is available?
  • J.J. 💎
    edited March 7, 2017
    Tyler and Andy,

    This issue has been resolved in Skuid Brooklyn - Iteration 1, which is now available on the Skuid Releases page.

    As a reminder, Salesforce does not allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. Thank you.
  • edited December 7, 2016
    Hi J,

    Getting even more errors than before now for some reason, looks like JqueryJS is private as well.

    image
  • J.J. 💎
    edited December 9, 2016
    I think I do see what's going on. Hang tight, and we'll get another fix out as soon as we can.
  • edited December 8, 2016
    I see there is a new release :). It seems to have fixed it completely!

    Thank you J.
  • MansourMansour ✭✭✭✭
    edited December 9, 2016
    I've had this issue as well.  I cloned the static resource, marked it as public, and added it as a static resource on the skuid page javascript.  
    We also had to add MomentJS to make the site work.

    Hope that works for you too.
  • J.J. 💎
    edited March 7, 2017
    This issue has been resolved in Skuid Brooklyn - Iteration 1.1, which is now available on the Skuid Releases page

    As a reminder, Salesforce does not allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. Thank you.
  • J.J. 💎
    edited December 9, 2016
    Yes, Iteration 1.1 is available now and should address the issues with the cache control settings. Tyler, thanks for letting us know that everything seems to be sorted for you now!

    Mansour, we added MomentJS to the list of public resources too. After installing Iteration 1.1, are you still having issues?
  • MansourMansour ✭✭✭✭
    edited December 9, 2016
    Works now - thanks
  • edited December 20, 2016
    Works! Thanks!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!