"Row in Model updated" only works the first time the model is loaded

edited March 2, 2017 in Questions
The action "Row in Model updated" is only working the first time the model is loaded. If you change the page or select a different item from the filters, it does not trigger the "Row in Model updated" action. What can I try here? Thanks in advance!

Comments

  • Zach McElrathZach McElrath Principal Software Engineer Chattanooga, TN 💎💎💎
    edited March 2, 2017
    Kyla, I think there's some confusion here with what the "Row in Model updated" action does. You're looking for the "Model requeried" event.

    The "Row in Model updated" event is only published when a user makes a change to a row, e.g. changing an Account's Name from "Acme" to "Blah". The "Model requeried" event is published when Models are first loaded, when you change filters, when you enter search text, etc --- any time that the Model is queried.
  • edited October 28, 2016
    Zach hit the nail on the head. Per our conversation yesterday, the actions you're taking are on the model (a Model action) instead of the row in the table (a Row action).

    That would explain a few things! I think I was able to steer you in the right direction. If not, go ahead and reach out and we can try a few other things.


  • edited August 24, 2016
    Yeah, I'm in a better place now. But man, I gotta tell you, the wrong choice of a Model Row Action and the right choice of a Table Row Action for what we actually wanted to do is a nuance that *REALLY* tripped me up. I'll get there though, if you're patient with me! Thanks again Will... & Zach too.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!