master page no longer available

Jack SanfordJack Sanford San Antonio, TX πŸ’ŽπŸ’Ž
edited February 17, 2020 in Questions
I have a master page that I've used in several places. Just tonight I've noticed it doesn't have "available as master page" checked and it's not checkable. The existing pages still have it as a master page, but I can't add any new child pages to it, and when I clone an existing child page it doesn't clone the master page connection.Β 

Any ideas? Still running Banzai 7.27.1 - should I upgrade to try and fix this?

Comments

  • edited February 17, 2020
    Hi Jack. Tested this with 7.24 & 7.27 working fine.

    Upgraded to 7.27.1 and got the same issue as you.

    Upgraded to 7.35 and problem remains.

    I suggest reporting this as a bug.


  • Rob HatchRob Hatch πŸ’ŽπŸ’ŽπŸ’Ž
    edited September 1, 2016
    Hmm. Β I'm on a 7.35 org and it seems to be working for me. Β 
  • J.J. πŸ’Ž
    edited March 7, 2017
    Jack,

    This is an odd one. I haven't seen any other reports of it. My best guess would be something with permissions, specifically, edit on the skuid__Page__c.IsMaster__c field. Can you verify that the user who did the install has either the Skuid Page Builder or Skuid Admin Permission Set (or both)?

    As for why you can't check the Available as a Master Page box in the Composer, it's because the Page still has Child Pages, so we disable the check box to prevent the situation you are in right now. Obviously, something got missed though. The quickest way to get the box checked again is to query for the Page record in the Salesforce Dev Console and manually update the value to true. Does that help?
  • Rob HatchRob Hatch πŸ’ŽπŸ’ŽπŸ’Ž
    edited September 1, 2016
    For those following along at home: Β The fields associated with Master pages on the Page object (isMaster and MasterPage) did not have any field level security applied to them. Β I think this is because of the installation permission set J. mentions above.Β 
  • Jack SanfordJack Sanford San Antonio, TX πŸ’ŽπŸ’Ž
    edited January 12, 2018
    Thanks Rob and J! Yes it was indeed that I didn't have the Skuid Admin NOR the Skuid Page Builder permission sets, so even though I'm a system admin I couldn't see those fields.Β 

    I think that this happened when I upgraded to 7.27, but really I guess it was a bug in previous versions that you could edit master-child page relationships without those permission sets.Β 

    Everything is working well now, the existing master page relationships have been restored and new ones can be added.Β 
  • edited February 17, 2020
    J is also correct in saying: "it's because the Page still has Child Pages". After deleting the child pages I could check or uncheck the 'Available as a Master Page' checkbox. Β In this case the installation was for all users. Boing!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!