Having Rich Text Data Type Field, does not the actual value after entered, saved the value.

edited February 10, 2017 in Questions
Having Rich Text Data Type Field, does not shows the actual value after entered, saved the value. It is showing the value when we click the edit. Is there any solution for this?

It seems the entered values taking as HTML, how to avoid it taking as HTML instead make it get displays actual data entered?

Comments

  • Rob HatchRob Hatch 💎💎💎
    edited September 1, 2016
    I'm not sure I understand.  By definition a rich text field is storing the full HTML string - so that formatting is maintained alongside the text entered in the control.  This means some amount of interpretation is going on and I can imagine that some "values" might be converted to formatting. 

    Can you let me know a little more specifically what the values you are enterring are that are not being stored as you would expect? 
  • edited August 31, 2015
    Hi Rob Hatch, i have attached screen shot for your reference.
  • edited February 10, 2017
    Hi image
  • Rob HatchRob Hatch 💎💎💎
    edited September 1, 2016
    Vijay - you are showing me one row of input and a different row of output.  Can you screenshot the same row?  Or maybe the expanation you had above the second page (that got cut off) had the necessary details. 
  • edited August 31, 2015
    Hi Rob,

    Just to help clarify, there are two issues here:
    1) We have a custom field renderer that renders a certain field inside of a drawer, based on the value of a picklist field called Data Type in the table row. See the table below for reference:image
    Something odd is occurring only with the rich text editor. When a value is entered into the rich text editor, and the model is saved (drawer closes automatically upon save), and I re-open the drawer, the value is not displaying:
    Screenshot of the value I typed in:
    image
    Screenshot after save and expanding the drawer:
    image
    It is not until I click the edit row action icon that the value re-appears, which leads me to the second issue:
    2) Values entered into the rich text field are displaying in HTML source format instead of the normal formatting in which I entered it (i.e. <p>,<li>,<ul>, etc. tags are appearing; apostrophe's are being converted to '&#39;' etc.). Below is a screenshot of the same drawer, after clicking the edit icon:
    image
    Setting the table inside of the drawer (which contains the rich text editor) to Edit mode instead of Read w/ in-line edit and removing the edit row action does not fix this issue. This particular issue only happens with the rich text fields (i.e. when data type is Rich text and thus the Rich_Text_Value__c field is rendered). It does not happen for text, true/false, etc.).

    Hope this helps. Please advise.
  • Matt SonesMatt Sones 💎💎💎
    edited December 7, 2016
    Not sure about the disappearance in readonly mode, but you can eliminate the source formatting by clicking the Source button in the top left corner of the rich text editor.
  • edited August 31, 2015
    Matt,

    The issue is that it appears to automatically convert the formatted value into HTML format prior to save. Thus, clicking the Source button results in no change.

    Are there any updates to the rich text fields coming with Banzai?
  • edited September 15, 2015
    Hi Matt Sones, this is to keep you informed that we have already tried pressing source which eliminating source format.  But it does not seems to cool, asking user to press frequently whenever he want to see rich text field value with out source format.

    We could not find any work around to make rich text field always source eliminates.

    Is there any work around which could help us! 

    Trey Alexander
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!