Validate field-level security when adding a field to a layout.

Ken McElrathKen McElrath ✭✭
edited December 29, 2015 in Ideas
I often will add a field to a Skuid Model and Page, but after saving the Page, cannot view the field I just added. In every case, this has been due to the field not having been assigned the appropriate field-level security settings when originally created in my object. (Setup > Customize > {Objectname} > Fields > etc.) It would be very helpful if Skuid could give me a warning when I try to add a field with inadequate field-level security settings. Something like: "{{fieldname}} does not have the appropriate field-level security settings to be made visible on this page. You will need to change the field-level security settings to make this field visible on this page." Even better, if I'm an admin, give me a pop-up that allows me to change field-level security settings for this field without the five clicks it typically takes to do this with the Salesforce Setup.
0
0 votes

Awaiting Review · Last Updated

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!